httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Cicimov <icici...@gmail.com>
Subject Re: [users@httpd] Struggle with Named Virtual Host - The SecondNamedVirtual HostAlways Returns 404 File Not Found Error
Date Tue, 18 May 2010 05:15:36 GMT
First, any .htaccess file by some chance that is messing up your config?
Second, It looks like the requests for download sub domain are heating the
main domain server ... can you confirm that in the access log for
debrass2.ana.bna.boeing.com (go to download-devbrass2.ana.bna.boeing.com and
tail -f the access file for debrass2.ana.bna.boeing.com to confirm that this
one is getting the request? Are you sure the DNS alias is properly set for
the download domain?


On Tue, May 18, 2010 at 2:30 PM, Wang, Mary Y <mary.y.wang@boeing.com>wrote:

>  Hmm.. It's getting interesting.. I reversed the order of the virtual host
> containers, and so now download-devbrass2 is the first virtual host and
> devbrass2 is the second virtual host.  To my surprise, download-devbrass is
> still not working but devbrass2 is still working.  I'm not sure if you saw
> my previous post, when I changed the Document content for devbrass2 to /home/project/tsim/htdocs,
> the file shows up.  So that tells me the file has the right permissions and
> does exist in the directory (I checked more than 10 times already :-(.
>
> Maybe other directives would have caused this behavior ( I mean may be not
> the Virtual Host container)?
>
>
> Mary
>
>
>  ------------------------------
> *From:* Peter J Milanese [mailto:PMilanese@nypl.org]
> *Sent:* Monday, May 17, 2010 9:18 PM
> *To:* users; Wang, Mary Y
> *Subject:* Re: [users@httpd] Struggle with Named Virtual Host - The
> SecondNamedVirtual HostAlways Returns 404 File Not Found Error
>
>  Silly question, did you try reversing the order of the virt containers?
> ------------------------------
>
> *  From: *"Smith, Cathy" [cathy.smith@pnl.gov]
> *  Sent: *05/17/2010 09:06 PM MST
> *  To: *"Wang, Mary Y" <mary.y.wang@boeing.com>; "users@httpd.apache.org"
> <users@httpd.apache.org>
> *  Subject: *RE: [users@httpd] Struggle with Named Virtual Host - The
> SecondNamed Virtual HostAlways Returns 404 File Not Found Error
>
>  Mary
>
>
>
> I just re-read the first posting, and should have asked if you are running
> Apache 2.0 or Apache 2.2.
>
>
>
> Cathy
>
> ---
> Cathy L. Smith
> IT Engineer
> Pacific Northwest National Laboratory
>
> Phone:  509.375.2687
> Fax:        509.375.2330
> Email:     cathy.smith@pnl.gov
>
>
>
>
>
> *From:* Wang, Mary Y [mailto:mary.y.wang@boeing.com]
> *Sent:* Monday, May 17, 2010 8:55 PM
> *To:* Smith, Cathy; users@httpd.apache.org
> *Subject:* RE: [users@httpd] Struggle with Named Virtual Host - The
> SecondNamed Virtual HostAlways Returns 404 File Not Found Error
>
>
>
> Cathy,
>
>
>
> It came with the system (I didn't build it from source).
>
> Basically, the main virtual host works, but the second virtual host just
> returns the 404 File Not Found Error (even when the file exists in that
> directory and permissions is correct)
>
>
>
> Mary
>
>
>  ------------------------------
>
> *From:* Smith, Cathy [mailto:cathy.smith@pnl.gov]
> *Sent:* Monday, May 17, 2010 8:48 PM
> *To:* Wang, Mary Y; users@httpd.apache.org
> *Subject:* RE: [users@httpd] Struggle with Named Virtual Host - The
> SecondNamed Virtual HostAlways Returns 404 File Not Found Error
>
> Mary
>
>
>
> Did you build Apache from source or get it as a Red Hat rpm?  I ran into
> what sounds like a similar problem.  I was running RHEL5 and built Apache
> 2.2.11 from source.
>
>
>
>
>
>
>
> Cathy
>
>
>
> ---
> Cathy L. Smith
> IT Engineer
> Pacific Northwest National Laboratory
>
> Phone:  509.375.2687
> Fax:        509.375.2330
> Email:     cathy.smith@pnl.gov
>
>
>
>
>
> *From:* Wang, Mary Y [mailto:mary.y.wang@boeing.com]
> *Sent:* Monday, May 17, 2010 8:44 PM
> *To:* Smith, Cathy; users@httpd.apache.org
> *Subject:* RE: [users@httpd] Struggle with Named Virtual Host - The Second
> Named Virtual HostAlways Returns 404 File Not Found Error
>
>
>
> Cathy,
>
>
>
> It's RHEL 3.9.
>
>
>
> Mary
>
>
>  ------------------------------
>
> *From:* Smith, Cathy [mailto:cathy.smith@pnl.gov]
> *Sent:* Monday, May 17, 2010 8:40 PM
> *To:* users@httpd.apache.org; Wang, Mary Y
> *Subject:* RE: [users@httpd] Struggle with Named Virtual Host - The Second
> Named Virtual HostAlways Returns 404 File Not Found Error
>
> Mary
>
>
>
> Did you mention what platform?
>
>
>
>
>
> Cathy
>
>
>
> ---
> Cathy L. Smith
> IT Engineer
> Pacific Northwest National Laboratory
>
> Phone:  509.375.2687
> Fax:        509.375.2330
> Email:     cathy.smith@pnl.gov
>
>
>
>
>
> *From:* Wang, Mary Y [mailto:mary.y.wang@boeing.com]
> *Sent:* Monday, May 17, 2010 8:37 PM
> *To:* users@httpd.apache.org
> *Subject:* RE: [users@httpd] Struggle with Named Virtual Host - The Second
> Named Virtual HostAlways Returns 404 File Not Found Error
>
>
>
> I checked.  The -x (execute) bit is turned for other, group and owner.  Any
> other ideas?
>
> Mary
>
>
>  ------------------------------
>
> *From:* Igor Cicimov [mailto:icicimov@gmail.com]
> *Sent:* Sunday, May 16, 2010 10:16 PM
> *To:* users@httpd.apache.org
> *Subject:* Re: [users@httpd] Struggle with Named Virtual Host - The Second
> Named Virtual HostAlways Returns 404 File Not Found Error
>
> Check the permissions for /home/project/tsim/htdocs
>
> Igor
>
> On Mon, May 17, 2010 at 2:16 PM, Tapas Mishra <mightydreams@gmail.com>
> wrote:
>
> > NameVirtualHost 134.51.151.114:80
> > <VirtualHost 134.51.151.114:80>
> > ServerName devbrass2.ana.bna.boeing.com:80
>
> ServerName is where apache2 listens to so do not add :80
> It will respond to this ServerName when a request comes on 134.51.151.114
> for
>
> devbrass2.ana.bna.boeing.com
>
> Otherwise you access the site as debrass2.ana.bna.boeing.com:80
>
> > DocumentRoot /usr/brass/www
> > ServerAdmin mary.y.wang@boeing.com
> > ErrorLog logs/error_log
>
> You can have some more meaningful name devbrass2_error_log (This is
> not related to your problem)
>
> > CustomLog logs/access_log combined
>
> Here also devbrass2_access_log
>
> > LogLevel debug
> > </VirtualHost>
> > <VirtualHost 134.51.151.114:80>
> > ServerName download-devbrass2.ana.bna.boeing.com:80
>
> Similarly here.
>
> > DocumentRoot /home/project/tsim/htdocs
> > ServerAdmin mary.y.wang@boeing.com
> > ErrorLog logs/error_log
>
> Similarly download-devbrass2_error_log
>
> > CustomLog logs/access_log combined
>
> Here also download-devbrass2_access_log
>
> > LogLevel debug
> > </VirtualHost>
> >
> > When I try to access download-devbrass2.ana.bna.boeing.com, I got this
> > error  "Not Found
> >
> > The requested URL / was not found on this server.
>
> > Additionally, a 404 Not Found error was encountered while trying to use
> an
> > ErrorDocument to handle the request" .
> /home/project/tsim/htdocs/index.html
> > does exist in that directory.  When I put this "DocumentRoot
> > /home/project/tsim/htdocs" for devbrass2.ana.bna.boeing.com, it returned
> the
> > index.html with no problem at all.  That was why made the conclusion, my
> > virtual host containers configuration only works for the 1st virtual
> > host container (the default host).
> >
> > Both devbrass2.ana.bna.boeing.com and
> download-devbrass2.ana.bna.boeing.com
> > have been registered as a DNS (download-devbrass2.ana.bna.boeing.com is
> > registered as an alias to devbrass2.ana.bna.boeing.com).
> >
> > Here is the returned status form apachectl -S:
> >
> > apachectl -S
> > /usr/sbin/apachectl: line 33: LD_ASSUME_KERNEL: command not found
> > VirtualHost configuration:
> > 134.51.151.114:80      is a NameVirtualHost
> >          default server devbrass2.ana.bna.boeing.com
> > (/etc/httpd/conf/httpd.conf:272)
> >          port 80 namevhost devbrass2.ana.bna.boeing.com
> > (/etc/httpd/conf/httpd.conf:272)
> >          port 80 namevhost download-devbrass2.ana.bna.boeing.com
> > (/etc/httpd/conf/httpd.conf:285)
> > Syntax OK
> >
> > Thanks in advance.
> >
> > Mary
> >
> > ________________________________
> > From: Igor Cicimov [mailto:icicimov@gmail.com]
> > Sent: Sunday, May 16, 2010 8:04 PM
> > To: users@httpd.apache.org
> > Subject: Re: [users@httpd] Struggle with Named Virtual Host - The Second
> > Named Virtual HostAlways Returns 404 File Not Found Error
> >
> > Post the relevant section of the config please so we can help you if you
> are
> > missing something.
> >
> > Igor
> >
> > On Mon, May 17, 2010 at 12:38 PM, Wang, Mary Y <mary.y.wang@boeing.com>
> > wrote:
> >>
> >> Oh..  apachectl -S shows it's a valid 80 namevhost.  The virtual host
> name
> >> has already been registered as a DNS (alias).  Just read another post
> about
> >> it, someone mentioned about adding the name to the /etc/hosts, and that
> >> didn't help either.
> >>
> >> Still searching for a solution...............
> >>
> >> Mary
> >>
> >>
> >>
> >> -----Original Message-----
> >> From: Wang, Mary Y
> >> Sent: Sunday, May 16, 2010 5:58 PM
> >> To: users@httpd.apache.org
> >> Subject: [users@httpd] Struggle with Named Virtual Host - The Second
> Named
> >> Virtual HostAlways Returns 404 File Not Found Error
> >>
> >> Hi,
> >>
> >> I've been struggling with Apache 2 named virtual hosts for a while that
> >> I've defined in the httpd.conf.  The second named virtual host never
> works,
> >> it always returns the 404 file not found error.  The DocumentRoot I
> declared
> >> for the second named virtual is correct, because when I put that
> information
> >> in the first named virtual host, it shows up.   After different tests,
> I've
> >> concluded that anything that I put in the DocumentRoot for the second
> name
> >> virtual host just always returns the 404 file not found error.  I even
> >> commented out a RewriteRule just to rule of any possibilities, and it
> still
> >> behaves the same.   Has anyone experienced this problem in Apache 2
> before ?
> >>  Both the named virtual hosts use the same IP address and running on
> port
> >> 80.   Is there something out there that I should look for?  I had no
> problem
> >> in Apache 1.3.7.
> >>
> >> Thanks in advance for any inputs.  I thought the migration from 1.3.x to
> 2
> >> shouldn't take that long, I guess I underestimated it :-(  .
> >>
> >> Mary
> >>
> >>
> >>
> >>
> >>
> >>
> >> ---------------------------------------------------------------------
> >> The official User-To-User support forum of the Apache HTTP Server
> Project.
> >> See <URL:http://httpd.apache.org/userslist.html> for more info.
> >> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> >>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> >> For additional commands, e-mail: users-help@httpd.apache.org
> >>
> >>
> >> ---------------------------------------------------------------------
> >> The official User-To-User support forum of the Apache HTTP Server
> Project.
> >> See <URL:http://httpd.apache.org/userslist.html> for more info.
> >> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> >>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> >> For additional commands, e-mail: users-help@httpd.apache.org
> >>
> >
> >
>
> --
> Tapas
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
>

Mime
View raw message