httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gaurav Chhabra <messag...@gmail.com>
Subject [users@httpd] Apache to Tomcat forwarding not working properly
Date Mon, 03 May 2010 15:57:14 GMT

Hi,


I am facing some problem with Apache to Tomcat forwarding. I have Tomcat
(6.0.18) behind Apache (2.2). I want to use ‘https’ for receiving request
from the client. This request, when forwarded by Apache to Tomcat, will use
‘http’. My application’s name is ‘abc’, which is deployed in Tomcat’s
webapps dir. Both Tomcat & Apache are on the same machine. There is one more
requirement: When a user just types the IP, it should, by default, forward
it to the application’s (abc) login page i.e., both the below mentioned
URL’s should point to the same page.

https://IP/
http://IP:8080/abc

I added the following lines in the httpd.conf file:
-----------------------------------------------------
ProxyPass /abc http://IP:8080/abc/implement
ProxyPass / http://IP:8080/abc/implement
-----------------------------------------------------

Now there are two issues:
-----------------------------------------------------
1. When I try to use the https URL (https://IP/), it opens up the login page
but the images are not visible. If I try the http one (http://IP:8080/abc/),
then the page works fine.

I thought of using the blank (appearing so) image’s URL
(https://IP/abc/abc/images/logo_login.gif >>> abc 2 times is not a typo; the
deployed directory’s name is ‘abc’ & there is a dir named ‘abc’ inside
‘abc’) and see where it’s pointing to. When I tried accessing it, it too was
pointing to the same login page where http://IP:8080/abc/ OR https://IP/ are
pointing.

These are few results that might help you to understand my problem:
https://IP/ (No logo; only the login page)
https://IP/abc/abc/images/logo_login.gif (No logo; only the login page)
(I have also noticed that whatever I append in the https URL after
https://IP/abc/ it takes me to the login page with no image)

http://IP:8080/abc/implement (Works perfectly. Login page with logo)
http://IP:8080/abc/implement/abc/images/logo_login.gif (Login page with
logo. I had no idea what this would display but at least I did not imagine
that it would display ‘login + image’)
http://IP:8080/abc/abc/images/logo_login.gif (Shows ONLY logo as it ideally
should)


2. If we use IE6 to open https URL, then a warning box pops-up before the
login page appears (without images). This behavior is absent in IE8.

The warning message states “line 56 Object expected”.
-----------------------------------------------------

Can anyone please guide me?


Regards,
GC 
-- 
View this message in context: http://old.nabble.com/Apache-to-Tomcat-forwarding-not-working-properly-tp28436856p28436856.html
Sent from the Apache HTTP Server - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message