httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mauri <lai...@gmail.com>
Subject Re: [users@httpd] Re: ProxyPreserveHost On
Date Mon, 26 Apr 2010 07:50:14 GMT
someone can help me? many thanks as usual.

for recap this is my problem:

When I digit https://mysite.com it becomes http://mysite.com because I think
that the proxypass is http.
It's wrong, I want that the URL will be https://mysite.com but I can use the
ProxyPreserveHost (one backend application need to this set).

this is my ssl.conf:

NameVirtualHost mysite.com:443
<VirtualHost mysite.com:443>
ProxyPreserveHost On
ProxyRequests off
ProxyPass / http://10.19.72.100:8080/
ProxyHTMLURLMap http://10.19.72.100:8080 /
<Location />
        ProxyPassReverse http://10.19.72.100:8080/
        ProxyHTMLEnable On
        ProxyHTMLURLMap  /      /
        RequestHeader    unset  Accept-Encoding
</Location>
[SSL directive...]


2010/4/23 Mauri <lain80@gmail.com>

>
> it's in ssl.conf, just
>
> # cat /etc/httpd/conf.d/ssl.conf
> [...]
>
> ProxyPreserveHost On
> ProxyRequests off
> ProxyPass / http://10.19.72.100:8080/
> ProxyHTMLURLMap http://10.19.72.100:8080 /
> <Location />
>         ProxyPassReverse http://10.19.72.100:8080/
>         ProxyHTMLEnable On
>         ProxyHTMLURLMap  /      /
>         RequestHeader    unset  Accept-Encoding
> </Location>
> [...]
>
> but It don't work in my httpd-2.2.3-31. The error is below in my previous
> mail.
>
> Cheers,
> Mauri
>
>
> 2010/4/23 GB GB <gbcyoyo@gmail.com>
>
> I had the exact same problem....
>> Instead of putting those lines in httpd.conf, try putting them in ssl.conf
>> I am running version 2.0.54, and ssl.conf directives worked for me.
>>
>> regards,
>>
>> On Fri, Apr 23, 2010 at 9:51 AM, Mauri <lain80@gmail.com> wrote:
>> >
>> > Someone can help me?
>> >
>> > cheers,
>> > Mauri
>> >
>> >
>> > 2010/4/22 Mauri <lain80@gmail.com>
>> >>
>> >> Hi experts,
>> >>
>> >> this is my scenario:  https://miosito.com --> mod_proxy -->
>> >> http://10.19.72.100:8080/ (tomcat)
>> >>
>> >> httpd conf:
>> >>
>> >> NameVirtualHost mysite.com:443
>> >> <VirtualHost mysite.com:443>
>> >> ProxyPreserveHost On
>> >> ProxyRequests off
>> >> ProxyPass / http://10.19.72.100:8080/
>> >> ProxyHTMLURLMap http://10.19.72.100:8080 /
>> >> <Location />
>> >>         ProxyPassReverse http://10.19.72.100:8080/
>> >>         ProxyHTMLEnable On
>> >>         ProxyHTMLURLMap  /      /
>> >>         RequestHeader    unset  Accept-Encoding
>> >> </Location>
>> >> [SSL directive...]
>> >>
>> >> When I digit
>> >> https://mysite.com it becomes http://mysite.com because I think that
>> hte
>> >> proxypass is http...
>> >> It's wrong, I want that the URL will be https://mysite.com but I can
>> use
>> >> the ProxyPreserveHost (one backend application need to this set).
>> >>
>> >> any idea?
>> >> many thanks, as usual.
>> >>
>> >> Cheers,
>> >> Mauri
>> >
>>
>> ---------------------------------------------------------------------
>> The official User-To-User support forum of the Apache HTTP Server Project.
>> See <URL:http://httpd.apache.org/userslist.html> for more info.
>> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>> For additional commands, e-mail: users-help@httpd.apache.org
>>
>>
>

Mime
View raw message