httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wang, Mary Y" <mary.y.w...@boeing.com>
Subject [users@httpd] Alias and HTTP 404 Not Found Error - But the file is THERE!
Date Sun, 25 Apr 2010 14:58:29 GMT
Hi,

I've been struggling with the following problem for two hours already, and read posts, blogs,
lists and Migration docs.  People suggested different things.
I'm in the process of migrating from Apache 1.3.x to Apache 2.0.46.  The code listed below
in the httpd.conf used to work on Apache 1.3.x, now I receive the HTTP 404 File Not Found
Error even though the file is there.  Please note the stuff declared in the conf.d/ssl.conf
used to be in conf/httpd.conf in Apache 1.3.x.

in /etc/httpd/conf httpd.conf
----------------
Alias /test-download/ /usr/test3.1/download/
<Directory /usr/test3.1/download>
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

in /etc/httpd/conf.d/ssl.conf
-----------------------------
<VirtualHost _default_:443>
ServerName download-devtest2.ana.bna.boeing.com
</VirtualHost>

When the URL goes there https://download-devtest2.ana.bna.boeing.com/test-download/devtest2-1/excel_download_error.bmp<https://download-devbrass2.ana.bna.boeing.com/brass-download/devbrass2-1/excel_download_error.bmp>,
I get the 404 File Not Found error.  Even though the file is there.

Is there something different about Apache 2.0.46 in the alias area?
Any suggestions or hints?

Thanks in advance.
Mary





---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message