httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kelly Vista <kvis...@gmail.com>
Subject [users@httpd] DocumentRoot on Windows
Date Mon, 08 Mar 2010 14:17:10 GMT
I am facing an odd problem, which may be specific to Windows (I'm
running 64-bit Windows 7 Home Premium).

With 2.2, I have it installed as a service (["...httpd.exe" -k
runservice] is the executable path).  Per the installation, I use the
ApacheMonitor.exe file to control apache.  However, when I modify
anything (DocumentRoot, authentication for a Directory), it does not
obey it when I restart Apache through the monitor.  On the other hand,
if I run httpd.exe in a console window (no args, just httpd.exe from
bin), no problem -- everything is obeyed.   I have tried quitting the
ApacheMonitor.exe and just started/stopped the service via Windows
services control, but to no avail.

I am thinking that the solution is in the executable path (perhaps I
should point to the conf file explicitly?).  I'm just surprised that
this requires as much hacking as it does, so I figure it must be me.
What am I doing wrong?

Thanks!

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message