httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chaminda Divitotawela <cdivitotaw...@yahoo.com>
Subject [users@httpd] HTTP-413 error when server recieves a blank POST
Date Wed, 03 Mar 2010 16:55:17 GMT
Hi,

I use httpd server 2.2.4.1 and due to some issue of one of the client application, client
sends a blank(with no payload) POST request. In this case httpd wait and times out and returns
the HTTP-413 error. HTTP-413 error indicates 'request entity too large'. However in this case
this error is not anything related to the size of the request content. I have not configured
LimitRequestBody in the apache server so there is no restriction imposed on the size of the
request.

I would like to know whether this is the correct error httpd suppose to send in such situation,
if so what is the explanation.

This is the information in the POST request and no further communication from the client.

POST /soap/publicationConsumerHttp_v1_0 HTTP/1.1 Content-type: text/xml; charset=utf-8..SOAPACTION:
"publish"..Transfer-Encoding: chunked..User-Agent: Java_1.6..Host: hostname..Accept: text/html,
image/gif, image/jpeg, */*; q=.2..Connection: Keep-Alive....  

I need to provide an explanation why httpd server return 413 error given that this is not
related to the size of the request. I have not configured the 

Many Thanks,
Chaminda


      

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message