httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J. Bakshi" <joyd...@infoservices.in>
Subject Re: [users@httpd] <IfModule mod_rewrite.c> issue in debian lenny.
Date Thu, 04 Mar 2010 07:15:51 GMT
On 03/04/2010 11:40 AM, Nilesh Govindarajan wrote:
> On Thu, Mar 4, 2010 at 11:12 AM, J. Bakshi <joydeep@infoservices.in
> <mailto:joydeep@infoservices.in>> wrote:
>
>     Hello list,
>
>     Here in debian lenny the rewrite rules are working well. I have
>     checked
>     by this .htaccess and successful
>
>     ````````````````````
>     DirectoryIndex index.php
>     RewriteEngine On
>
>     #RewriteRule ^typo3$ - [L]
>     #RewriteRule ^typo3/.*$ - [L]
>
>     RewriteCond %{REQUEST_FILENAME} !-f
>     RewriteCond %{REQUEST_FILENAME} !-d
>     RewriteCond %{REQUEST_FILENAME} !-l
>     RewriteRule .* index.php
>     ```````````````
>
>
>     Now I like to place the rewrite stuff in apache configuration so
>     that I
>     don't need to place .htaccess for all the sites. and here is the
>     config
>     I have placed in apache
>
>     ```````````````````````
>     <Directory /var/www/>
>     Options Indexes FollowSymLinks MultiViews
>     # .htaccess slows down apache; only use it when required #
>     AllowOverride All
>     Order allow,deny
>     allow from all
>
>     ### Begin: Rewrite stuff for typo3 ###
>     <IfModule mod_rewrite.c>
>
>     # Enable URL rewriting
>     RewriteEngine On
>     RewriteBase /
>
>     RewriteCond %{REQUEST_FILENAME} !-f
>     RewriteCond %{REQUEST_FILENAME} !-d
>     RewriteCond %{REQUEST_FILENAME} !-l
>
>     RewriteRule .* index.php [L]
>     </IfModule>
>     </Directory>
>
>     ````````````````````````````````
>
>     restart apache and remove the .htaccess from webroot directory of the
>     site. the rewite stuff is not working now !!! Is it a problem with
>     <IfModule mod_rewrite.c> which is not recognized here in lenny ? Does
>     anyone have any idea or faced the same problem.
>
>     BTW: The above config running fine with opensuse 11.2
>
>     Thanks
>
>     --
>     জয়দীপ বক্সী
>
>
>
>
> I think you should be using rewrite_module.c instead of mod_rewrite.c
>
>

Checked by  <IfModule rewrite_module.c> but no luck.  How can I check
the correct module in my server ?

Thanks


-- 
জয়দীপ বক্সী


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message