httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anand Sathe <anand_sa...@yahoo.com>
Subject [users@httpd] mod_deflate logging issue when not using virtual hosts
Date Tue, 23 Feb 2010 05:40:50 GMT
Trying one more time as the earlier post failed to garner any replies :)
Any help appreciated
Anand
-----------



> Hi,
> I am having a peculiar issue with turning on logging for
> mod_deflate.
> 
> Environment:
> Apache 2.2.6 running on Linux (SuSE 11 x86 64 bit).
> I have no virtual hosts defined - all my configuration is
> in httpd.conf
>  Here is a snapshot of my httpd.conf
> --------------------------------------------------
> # Filters allow you to process content before it is sent to
> the client.
> 
> <IfModule deflate_module>
>      AddOutputFilterByType DEFLATE text/html text/plain
> text/xml application/xml application/xhtml+xml 
> 
> text/javascript text/css application/x-javascript
>      BrowserMatch ^Mozilla/4 gzip-only-text/html
>      BrowserMatch ^Mozilla/4.0[678] no-gzip
>      BrowserMatch bMSIE !no-gzip !gzip-only-text/html
>      DeflateCompressionLevel 9
>      DeflateFilterNote Input instream
>      DeflateFilterNote Output outstream
>      DeflateFilterNote Ratio ratio
>      LogFormat '"%r" %{outstream}n/%{instream}n
> (%{ratio}n%%)' DEFLATE
>      DeflateFilterNote ratio
>      LogFormat '"%r" %b (%{ratio}n) "%{User-agent}i"'
> DEFLATE
>      CustomLog logs/deflate_log DEFLATE
> </IfModule>
> 
> 
> The Problem: 
> Content is getting zipped as expected. However, the custom
> log (logs/deflate_log) gets created but stays empty -
> nothing ever is recorded there.
> I AM aware of this issue as mentioned in the httpd docs:
> " If CustomLog or ErrorLog directives are placed inside a
> <VirtualHost> section, all requests or errors for that
> virtual host will be logged only to the specified file. Any
> virtual host which does not have logging directives will
> still have its requests sent to the main server logs."
> 
> However, since i do not have a virtual hosts section
> defined and my CustomLog and ErrorLog directives are for the
> entire server, this should not apply to me (i think?)
> 
> Any help appreciated
> Thanks!
> Anand
> 
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP
> Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more
> info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 


      

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message