httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krzysztof Serwin <kser...@hotmail.co.uk>
Subject [users@httpd] apache 2.2.3 centos 5.4 httpd.worker seg fault
Date Wed, 06 Jan 2010 11:24:32 GMT

I would like to say hello to you all and say as an introduction that I am really rarely using
mailing lists but this time I have run out of other options.
Shortly, I am using httpd 2.2.3 running on Centos 5.4 which causes some problems as soon as
soon as I switch it to use Worker MPM by editing /etc/sysconfig/httpd and adding line:
HTTPD=/usr/sbin/httpd.worker

It has configured quite a lot of virtual hosts. There will be more than a 100 of them.

As soon as Worker MPM starts I get this in error_log:

[Wed Jan 06 10:44:08 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Jan 06 10:44:09 2010] [notice] ModSecurity for Apache/2.5.9 (http://www.modsecurity.org/)
configured.
[Wed Jan 06 10:44:17 2010] [notice] Digest: generating secret for digest authentication ...
[Wed Jan 06 10:44:17 2010] [notice] Digest: done
[Wed Jan 06 10:44:19 2010] [notice] Apache configured -- resuming normal operations
libgcc_s.so.1 must be installed for pthread_cancel to work
libgcc_s.so.1 must be installed for pthread_cancel to work
libgcc_s.so.1 must be installed for pthread_cancel to work
libgcc_s.so.1 must be installed for pthread_cancel to work
libgcc_s.so.1 must be installed for pthread_cancel to work
libgcc_s.so.1 must be installed for pthread_cancel to work
libgcc_s.so.1 must be installed for pthread_cancel to work
libgcc_s.so.1 must be installed for pthread_cancel to work
libgcc_s.so.1 must be installed for pthread_cancel to work
libgcc_s.so.1 must be installed for pthread_cancel to work
[Wed Jan 06 10:44:26 2010] [notice] child pid 6092 exit signal Aborted (6)
[Wed Jan 06 10:44:26 2010] [notice] child pid 6093 exit signal Aborted (6)
[Wed Jan 06 10:44:26 2010] [notice] child pid 6094 exit signal Aborted (6)
[Wed Jan 06 10:44:26 2010] [notice] child pid 6095 exit signal Aborted (6)

I noticed that disabling some of the virtual hosts gets this error away - it doesn't matter
which ones are disabled.


Versions of software in use:
httpd.x86_64                                                        2.2.3-31.el5.centos.2
apr.x86_64                                                            1.2.7-11.el5_3.1   
                                                        
glibc.i686                            2.5-42.el5_4.2                                     
                                                
glibc.x86_64                                                                             
        2.5-42.el5_4.2

I tried to debug with gdb with the result:

[root@apachetest ~]# ps -aux  | grep httpd.worker
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.7/FAQ
root      5780  0.0  2.4 221136 51096 ?        Ts   10:44   0:00 /usr/sbin/httpd.worker
apache   14127  0.0  0.0      0     0 ?        Z    11:17   0:00 [httpd.worker] <defunct>
root     14171  0.0  1.2  99316 25880 pts/0    S+   11:17   0:00 gdb /usr/sbin/httpd.worker
5780
root     16646  0.0  0.0  61152   728 pts/1    R+   11:18   0:00 grep httpd.worker

[root@apachetest ~]# gdb /usr/sbin/httpd.worker 5780
GNU gdb Fedora (6.8-37.el5)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
(no debugging symbols found)
Attaching to program: /usr/sbin/httpd.worker, process 5780
(no debugging symbols found)
Loaded symbols for /usr/sbin/httpd.worker
Reading symbols from /lib64/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib64/libm.so.6
Reading symbols from /lib64/libpcre.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib64/libpcre.so.0
Reading symbols from /lib64/libselinux.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libselinux.so.1
Reading symbols from /usr/lib64/libaprutil-1.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libaprutil-1.so.0
Reading symbols from /lib64/libcrypt.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libcrypt.so.1
Reading symbols from /usr/lib64/libldap-2.3.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libldap-2.3.so.0
Reading symbols from /usr/lib64/liblber-2.3.so.0...
(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/liblber-2.3.so.0
Reading symbols from /lib64/libdb-4.3.so...(no debugging symbols found)...done.
Loaded symbols for /lib64/libdb-4.3.so
Reading symbols from /lib64/libexpat.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib64/libexpat.so.0
Reading symbols from /usr/lib64/libapr-1.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libapr-1.so.0
Reading symbols from /lib64/libpthread.so.0...(no debugging symbols found)...done.
[Thread debugging using libthread_db enabled]
[New Thread 0x2b7a572c6560 (LWP 5780)]
Loaded symbols for /lib64/libpthread.so.0
Reading symbols from /lib64/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libdl.so.2
Reading symbols from /lib64/libc.so.6...
(no debugging symbols found)...done.
Loaded symbols for /lib64/libc.so.6
Reading symbols from /lib64/libsepol.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libsepol.so.1
Reading symbols from /lib64/ld-linux-x86-64.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/ld-linux-x86-64.so.2
Reading symbols from /lib64/libuuid.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libuuid.so.1
Reading symbols from /usr/lib64/libpq.so.4...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libpq.so.4
Reading symbols from /usr/lib64/libsqlite3.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libsqlite3.so.0
Reading symbols from /lib64/libresolv.so.2...
(no debugging symbols found)...done.
Loaded symbols for /lib64/libresolv.so.2
Reading symbols from /usr/lib64/libsasl2.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libsasl2.so.2
Reading symbols from /lib64/libssl.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib64/libssl.so.6
Reading symbols from /lib64/libcrypto.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib64/libcrypto.so.6
Reading symbols from /usr/lib64/libkrb5.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libkrb5.so.3
Reading symbols from /lib64/libnsl.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libnsl.so.1
Reading symbols from /usr/lib64/libgssapi_krb5.so.2...
(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libgssapi_krb5.so.2
Reading symbols from /lib64/libcom_err.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib64/libcom_err.so.2
Reading symbols from /usr/lib64/libk5crypto.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libk5crypto.so.3
Reading symbols from /usr/lib64/libz.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libz.so.1
Reading symbols from /usr/lib64/libkrb5support.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libkrb5support.so.0
Reading symbols from /lib64/libkeyutils.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib64/libkeyutils.so.1
Reading symbols from /usr/lib64/httpd/modules/mod_auth_basic.so...
(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_auth_basic.so
Reading symbols from /usr/lib64/httpd/modules/mod_auth_digest.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_auth_digest.so
Reading symbols from /usr/lib64/httpd/modules/mod_authn_file.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authn_file.so
Reading symbols from /usr/lib64/httpd/modules/mod_authn_alias.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authn_alias.so
Reading symbols from /usr/lib64/httpd/modules/mod_authn_anon.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authn_anon.so
Reading symbols from /usr/lib64/httpd/modules/mod_authn_dbm.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authn_dbm.so
Reading symbols from /usr/lib64/httpd/modules/mod_authn_default.so...
(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authn_default.so
Reading symbols from /usr/lib64/httpd/modules/mod_authz_host.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authz_host.so
Reading symbols from /usr/lib64/httpd/modules/mod_authz_user.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authz_user.so
Reading symbols from /usr/lib64/httpd/modules/mod_authz_owner.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authz_owner.so
Reading symbols from /usr/lib64/httpd/modules/mod_authz_groupfile.so...(no debugging symbols
found)...done.
Loaded symbols for /etc/httpd/modules/mod_authz_groupfile.so
Reading symbols from /usr/lib64/httpd/modules/mod_authz_dbm.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authz_dbm.so
Reading symbols from /usr/lib64/httpd/modules/mod_authz_default.so...
(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authz_default.so
Reading symbols from /usr/lib64/httpd/modules/mod_ldap.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_ldap.so
Reading symbols from /usr/lib64/httpd/modules/mod_authnz_ldap.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_authnz_ldap.so
Reading symbols from /usr/lib64/httpd/modules/mod_include.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_include.so
Reading symbols from /usr/lib64/httpd/modules/mod_log_config.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_log_config.so
Reading symbols from /usr/lib64/httpd/modules/mod_env.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_env.so
Reading symbols from /usr/lib64/httpd/modules/mod_mime_magic.so...
(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_mime_magic.so
Reading symbols from /usr/lib64/httpd/modules/mod_expires.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_expires.so
Reading symbols from /usr/lib64/httpd/modules/mod_deflate.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_deflate.so
Reading symbols from /usr/lib64/httpd/modules/mod_setenvif.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_setenvif.so
Reading symbols from /usr/lib64/httpd/modules/mod_mime.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_mime.so
Reading symbols from /usr/lib64/httpd/modules/mod_status.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_status.so
Reading symbols from /usr/lib64/httpd/modules/mod_autoindex.so...
(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_autoindex.so
Reading symbols from /usr/lib64/httpd/modules/mod_info.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_info.so
Reading symbols from /usr/lib64/httpd/modules/mod_vhost_alias.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_vhost_alias.so
Reading symbols from /usr/lib64/httpd/modules/mod_negotiation.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_negotiation.so
Reading symbols from /usr/lib64/httpd/modules/mod_dir.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_dir.so
Reading symbols from /usr/lib64/httpd/modules/mod_alias.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_alias.so
Reading symbols from /usr/lib64/httpd/modules/mod_rewrite.so...
(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_rewrite.so
Reading symbols from /usr/lib64/httpd/modules/mod_proxy.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_proxy.so
Reading symbols from /usr/lib64/httpd/modules/mod_proxy_balancer.so...(no debugging symbols
found)...done.
Loaded symbols for /etc/httpd/modules/mod_proxy_balancer.so
Reading symbols from /usr/lib64/httpd/modules/mod_proxy_ftp.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_proxy_ftp.so
Reading symbols from /usr/lib64/httpd/modules/mod_proxy_http.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_proxy_http.so
Reading symbols from /usr/lib64/httpd/modules/mod_proxy_connect.so...(no debugging symbols
found)...done.
Loaded symbols for /etc/httpd/modules/mod_proxy_connect.so
Reading symbols from /usr/lib64/httpd/modules/mod_suexec.so...
(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_suexec.so
Reading symbols from /usr/lib64/httpd/modules/mod_cgi.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_cgi.so
Reading symbols from /usr/lib64/httpd/modules/mod_version.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_version.so
Reading symbols from /usr/lib64/httpd/modules/mod_security2.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_security2.so
Reading symbols from /usr/lib64/libxml2.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libxml2.so.2
Reading symbols from /usr/lib64/liblua-5.1.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/liblua-5.1.so
Reading symbols from /usr/lib64/httpd/modules/mod_unique_id.so...
(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_unique_id.so
Reading symbols from /usr/lib64/httpd/modules/mod_proxy_ajp.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_proxy_ajp.so
Reading symbols from /usr/lib64/httpd/modules/mod_ssl.so...(no debugging symbols found)...done.
Loaded symbols for /etc/httpd/modules/mod_ssl.so
Reading symbols from /usr/lib64/libdistcache.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libdistcache.so.1
Reading symbols from /usr/lib64/libnal.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib64/libnal.so.1
0x00002b7a54c84e83 in __select_nocancel ()
   from /lib64/libc.so.6
(gdb) where
#0  0x00002b7a54c84e83 in __select_nocancel () from /lib64/libc.so.6
#1  0x00002b7a545902f5 in apr_sleep () from /usr/lib64/libapr-1.so.0
#2  0x00002b7a52cc35d5 in ap_wait_or_timeout () from /usr/sbin/httpd.worker
#3  0x00002b7a52ccd233 in ap_mpm_run () from /usr/sbin/httpd.worker
#4  0x00002b7a52ca77e0 in main () from /usr/sbin/httpd.worker

I also tried adding directive 
LoadFile /lib64/libgcc_s.so.1
to config.

It gets  libgcc_s.so.1 must be installed for pthread_cancel to work error awaym but seg fault
stays.

Is there anything else I can do to find out what is the problem?

K.
 		 	   		  
_________________________________________________________________
Use Hotmail to send and receive mail from your different email accounts
http://clk.atdmt.com/UKM/go/186394592/direct/01/
Mime
View raw message