httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ricardo figueiredo <ricardoogra...@gmail.com>
Subject Re: [users@httpd] How install sub mod
Date Mon, 04 Jan 2010 12:37:45 GMT
Remember,

I haven't problems with the older revision (rev. 594659)
I have problems with the newest revision (rev. 774239)

Ricardo

On Mon, Jan 4, 2010 at 10:07 AM, ricardo figueiredo <
ricardoogrande@gmail.com> wrote:

> Well, I compiled mod_lbmethod_rr.c with APXS (apxs -a -i -c
> mod_lbmethod_rr.c)
> During compilation there were some WARNINGS
>
> 111:warning:excess elements in struct initializer
> 111:warning:(near initialization for 'round robin')
> 113:warning:excess elements in struct initializer
> 111:warning:(near initialization for 'round robin')
>
> When I started APACHE and loaded web page in browser, doesn't show the web
> page.
> I saw logs/error.log and there is a SEGMENTATION FAULT.
>
> My httpd.conf:
>
> LoadModule proxy_balancer_rr_module modules/mod_lbmethod_rr.so
>
> ProxyPass /index1.php balancer://cluster1/
> ProxyPass /index2.php balancer://cluster2/
>
> <Proxy balancer://cluster1/>
>        ProxySet lbmethod=roundrobin
>        BalancerMember http://192.168.1.11/index1.php
>        BalancerMember http://192.168.1.12/index1.php
>        BalancerMember http://192.168.1.13/index1.php
>        BalancerMember http://192.168.1.14/index1.php
> </Proxy>
>
> <Proxy balancer://cluster2/>
>        ProxySet lbmethod=roundrobin
>        BalancerMember http://192.168.1.15/index2.php
>        BalancerMember http://192.168.1.16/index2.php
> </Proxy>
>
> I haven't problems with others algorithms.
>
> Ricardo
>
>
> On Sun, Jan 3, 2010 at 1:47 PM, Eric Covener <covener@gmail.com> wrote:
>
>> On Sun, Jan 3, 2010 at 6:46 AM, ricardo figueiredo
>> <ricardoogrande@gmail.com> wrote:
>> > I'd like to how I install a sub module.
>> > I'm trying to install mod_lbmethod_rr.c (Revision 774239).
>> > I install APACHE using the following:
>> > ./configure --prefix=/apache/path --enable-proxy --with-mpm=worker &&
>> make
>> > && make install
>>
>> Hrm, do you need to explicitly enable DSO support (--enable-so)?
>>
>> --
>> Eric Covener
>> covener@gmail.com
>>
>> ---------------------------------------------------------------------
>> The official User-To-User support forum of the Apache HTTP Server Project.
>> See <URL:http://httpd.apache.org/userslist.html> for more info.
>> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>> For additional commands, e-mail: users-help@httpd.apache.org
>>
>>
>
>
> --
> Muito Obrigado
>
> Ricardo
>



-- 
Muito Obrigado

Ricardo

Mime
View raw message