httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pravesh Rai <pravesh....@gmail.com>
Subject [users@httpd] Fwd: Getting "Error reading header" messages in error_log
Date Mon, 04 Jan 2010 11:28:16 GMT
Gentle reminder. Appreciate any clue for this question.

Thanks,
Pravesh

---------- Forwarded message ----------
From: Pravesh Rai <pravesh.rai@gmail.com>
Date: Wed, Dec 16, 2009 at 5:36 PM
Subject: Getting "Error reading header" messages in error_log
To: users@httpd.apache.org


Hi,

We are getting either of the following error messages in error_log:

[error] [client ::1] client sent HTTP/1.1 request without hostname
(see RFC2616 section 14.23): /proxy/ssllogin, referer: <URL>

Or

[error] [client 127.0.0.1] request failed: error reading the headers,
referer: <URL>

& ultimately gets "Http 400 Page Cannot be Displayed" error page.

Further digging into the problem shows that even ap_rgetline_core()
[protocols.c] reads the HTTP header data wrongly. Some of the header
fields are either missing or overrun to other fields. Do anybody have
any idea on this ?

FYI, we are using Apache 2.2.6, PHP 5.2.9 & Openssl 0.9.8k for
building web-server.

Thanks & Regards,
Pravesh

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message