httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaigates <jaiga...@gmail.com>
Subject [users@httpd] Application links doesnt not point to apache url
Date Thu, 28 Jan 2010 10:55:19 GMT

hi
i want to set up apache http server to work like below

when user enter http://localhost/XYZ(proxy server) it should route to
http://10.x.x.x:8080/XYX(proxy server) 
If the page returned from the application server contains  /XYZ/viewUsers.do 
and when i click this link it directs to
http://10.x.x.x:8080/XYZ/viewUsers.do but this should direct to
http://locahost/XYZ/viewUsers.do

i have just configured rewrite rule like below
<IfModule rewrite_module>
    RewriteEngine		on
	RewriteCond     %{SERVER_PORT} ^80$
	RewriteRule     ^(.*)$ http://10.x.x.x:8080%{REQUEST_URI} 
</IfModule>

Basically the links or any url should always point to proxy server.

Can any one help


-- 
View this message in context: http://old.nabble.com/Application-links-doesnt-not-point-to-apache-url-tp27354134p27354134.html
Sent from the Apache HTTP Server - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message