httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J. Bakshi" <joyd...@infoservices.in>
Subject Re: [users@httpd] speaking url is not working inside subfolder
Date Wed, 20 Jan 2010 11:06:11 GMT
On Wed, 20 Jan 2010 10:19:24 +0100
Krist van Besien <krist.vanbesien@gmail.com> wrote:

> On Tue, Jan 19, 2010 at 5:28 PM, J. Bakshi <joydeep@infoservices.in>
> wrote:
> 
> > The .htccess successfully redirects the concerned domain into the
> > sub-folder (TYPO3) . But the problem is with speaking url. Clicking
> > on any links always and always goes to the very first page.
> 
> Waht is a "speaking url"?
> Could it be that your problem simply is that Typo3 is unaware it
> exists in a subfolder, and thus creates URLs that do not start with
> TYPO3?
> 
> Krist
>

"speaking url" or "real url" is human understandable url. Say http://mydomain.com/?index.php=43
will be http://mydomain.com/homepage.html

Your point is relevant as typo3 speaking-url is working well from public_html but not from
public_html/TYPO3 folder. .htaccess is already there in public_html to handle the redirection,
then what else do I need to fix it ? My .htacces is

` ` `
Options +FollowSymLinks
RewriteEngine on

# domain for typo3

RewriteCond %{HTTP_HOST} ^(www.)domain.in$
RewriteCond %{REQUEST_URI} !^/TYPO3/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule ^(.*)$ /TYPO3/$1
RewriteCond %{HTTP_HOST} ^(www.)domain.in$
RewriteRule ^(/)?$ TYPO3/index.php [L]

` ` `

Thanks

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message