httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Copeland <ch...@cope360.com>
Subject Re: [users@httpd] HTTP fine, SSL segfaults every time; 2.2.14 on Solaris 10 x86. Backtrace included
Date Tue, 22 Dec 2009 18:02:33 GMT
Jeff, thanks for the help.  Replacing that file solved my problem.

I could use some guidance on what to do now.  I am building packages
for use on production servers.

 * Would 2.2.14 with this patch suitable for use on a production server?
 * Would an earlier version of 2.2 be better for my Solaris 10 x86 environment?
 * Should I wait for a release that includes these changes?

Any advice greatly appreciated.

-Chris

On Fri, Dec 18, 2009 at 6:47 PM, Jeff Trawick <trawick@gmail.com> wrote:
> Are you using the APR bundled with httpd?  If so, please replace
> srclib/apr/pool/unix/port.c with the latest version:
>
> http://svn.apache.org/viewvc/apr/apr/branches/1.3.x/poll/unix/port.c?revision=836111&view=co
>
> I don't recognize the backtrace you posted, but that logic is in the
> general vicinity of two important fixes.  One is specific to 32-bit
> builds on Solaris 10 x86; the other is necessary for all Solaris 10 or
> OpenSolaris.
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message