httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "R. M. Pretzlaw" <mikescr...@gmx.de>
Subject [users@httpd] Configuration leads to error
Date Mon, 28 Dec 2009 12:51:34 GMT
Hello. Beside other configurations I got this VirtualHost:

     <VirtualHost *:200>
         DocumentRoot "D:/develop"

         <Directory "D:/develop">
             Options Indexes FollowSymLinks Includes ExecCGI
             AllowOverride All
             Order allow,deny
             Allow from all
         </Directory>

         Alias /foo G:/Documents/web/foo
     </VirtualHost>

     <Directory "G:/Documents/web/foo">
         Options -Indexes FollowSymLinks Includes ExecCGI
         AllowOverride All
         Order allow,deny
         Allow from all
     </Directory>

And in "G:/Documents/web/foo/trunk" this .htacces lines when i call
http://127.0.0.1:200/foo/trunk :

     RewriteRule ^[.]{0}$ _index.php?u= [L,QSA]
     RewriteRule ^([^_]+)$ _index.php?u=$1 [L,QSA]

But Apache can't find the file. It writes this in error.log :
"File does not exist: D:/develop/Documents"

So it seems that Alias doesn't take the drive-letter when rewriting an url.

Whats so confusing about my configutation?
How would it be right? (if I want a VirtualHost and a directory (like an
Alias) that is not in the DocumentRoot)


Greetings,
RMP

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message