httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajasundari <Rajasundari.Kaliaperu...@Sun.COM>
Subject [users@httpd] In AIX, while setting "cookie" value in request headers, using apr_table_get(), the previous key-value gets removed.
Date Mon, 07 Dec 2009 12:58:43 GMT
Hi,

I am using apache 2.0 on AIX.

I am using  apr_table_set(r->headers_in, key ,values) to set  the key 
and value in the headers.

When I call this API with key as "Cookie", it erases the previous 
attribute value pair.
So some attributes are getting missed  in the request headers.

As a workaround I tried calling this API with key as "Cookie" first and 
then for the other key values. It works fine now.
But I would like to know the reason behind this and would expect a fix.
I can't change my application without a proper justification.

Also, to debug this, I used apr_table_do() which  printed only the first 
key-value pair and not the full table.

FYI,  in Solaris,  the same code is working fine
apr_table_set() - works well for setting attributes and "Cookie" in any 
sequence.
apr_table_do() -  prints the entire list.

Please throw light on this.

Waiting for your response.

Thanks
Rajasundari




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message