httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Devraj Mukherjee <dev...@gmail.com>
Subject [users@httpd] HTTPS connections via mod_proxy ProxyRemote don't work
Date Fri, 04 Dec 2009 05:27:34 GMT
Hi all,

I am using Apache as a reverse proxy (primarily because we use
mod_substitute, mod_heads to add Firefox CSS fixes to a web
application provided by a third party for our users). Essentially its
setup as a VirtualHost that reverse proxies the requests to the
external site.

The complication is that this reverse proxy sits in our corporate
network and all external traffic goes through a Squid proxy server. I
am routing the reverse proxy traffic through squid using the
ProxyRemote directive and all works well for HTTP connections.

The external web site has switched to HTTPS and now when I try and
proxy the connection over HTTPS it says

The timeout specified has expired: proxy: HTTPS: attempt to connect ...
ap_proxy_connect_backend disabling worker for (...

Any ideas if I need to do something special when using ProxyRemote and HTTPS?

Thanks.

-- 
"The secret impresses no-one, the trick you use it for is everything"
- Alfred Borden (The Prestiege)

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message