httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boyle Owen" <Owen.Bo...@six-group.com>
Subject RE: [users@httpd] mod_proxy issue - intermittent 502 response
Date Fri, 27 Nov 2009 09:16:47 GMT
502 is bad gateway, which means that apache and the back-end server have
got into a protocol argument. Usually this is due to a bad response from
the back-end (as your log entries indicate). Why do you think apache is
the problem?

Rgds,
Owen Boyle
Disclaimer: Any disclaimer attached to this message may be ignored.  


________________________________

	From: Cristian Pini [mailto:cris.pini@fsite.com] 
	Sent: Thursday, November 26, 2009 6:19 PM
	To: users@httpd.apache.org
	Subject: [users@httpd] mod_proxy issue - intermittent 502
response
	
	

	Hi,

	 

	I'm running Apache/2.0.52 as a reverse proxy on a RHE4 box, the
backend app server is on a separate machine again RHE4, running
Apache/2.0.52 and mod_perl 1.99_16. 

	 

	There are intermittent 502 responses being generated by the
proxy although a page refresh generally resolves the issue, we are
trying to get a configuration of 2 RP boxes in front of 3 mod_perl app
servers into production but will need to understand / resolve the issue
of these intermittent 502 responses first.

	 

	[Thu Nov 26 15:35:09 2009] [error] [client 88.96.233.45] proxy:
error reading status line from remote server xxx.xxxxxx.co.uk, referer:
http://xxx.xxxx.co.uk/mens/casual/casual/71/brand-/all-/start-

	[Thu Nov 26 15:35:09 2009] [error] [client 88.96.233.45] proxy:
Error reading from remote server returned by
/mens/smart/smart/70/brand-/all-/start-, referer:
http://xxxx.xxxxxxx.co.uk/mens/casual/casual/71/brand-/all-/start-

	 

	Can someone shed further light on what the problem is and how to
resolve it pls, I'm happy to send virtual host confs if someone wishes
to dig little deeper. Note at this point I'm using mod_rewrite [P] to
proxy the requests to the app server rather than using ProxyPass as we
have many rewrites in the conf.

	 

	I've googled around and have seen that others have observed
similar scenarios when using this setup in Apache 2.0 but have not seen
anything specific about a resolution or path to resolution.

	 

	Your help gratefully appreciated.

	 

	Kind regards,

	 

	Cris

	 

	Cristian Pini

	Foresite Business Solutions Ltd

	Tel: 020 8540 0040

	Direct: 020 8545 6813

	http://www.fsite.com 
 
This message is for the named person's use only. It may contain confidential, proprietary
or legally privileged information. If you receive this message in error, please notify the
sender urgently and then immediately delete the message and any copies of it from your system.
Please also immediately destroy any hardcopies of the message. 
The sender's company reserves the right to monitor all e-mail communications through their
networks.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message