httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sheryl" <gubyd...@his.com>
Subject Re: [users@httpd] ssl - apache - solaris
Date Thu, 05 Nov 2009 16:48:21 GMT

> ../configure --prefix=/appl/apache1 --enable-mods-shared=most --enable-ssl
> --with-ssl=/usr/local/ssl/
[snip]
> "Cannot load /appl/apache1/modules/mod_ssl.so into server: ld.so.1: httpd:
> fatal: relocation error: file /appl/apache1/modules/mod_ssl.so: symbol
> SSL_CTX_sess_set_new_cb: referenced symbol not found"

I suspect that it doesn't know where to find the library.  You can confirm
this by running "ldd httpd" on the http daemon.  If that's the case, try
adding the ssl library directory to the LD_LIBRARY_PATH (probably
/usr/local/ssl/lib) in the envvars file in the apache bin directory.

It's also possible to set up the RPATH during the configure/compile step
to set the location of the library within the binary but not usually
necessary.  Using envvars works too.

> I tried it on Apache 2.2.13 / Apache 2.2.11 / Apache 2.0.63 / Apache
> 2.0.59
>
> Any pointers what i am missing ?
>
> Thanks
> Singh
>



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message