httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bastien Semene <bsem...@cyanide-studio.com>
Subject Re: RE: [users@httpd] mod_proxy configuration issue
Date Wed, 25 Nov 2009 14:43:51 GMT
The default vhost was the problem.
I renamed the vhost file so it is loaded first and it works like a charm 
now.

Thanks a lot.

Emmanuel Bailleul a écrit :
>> -----Message d'origine-----
>> De : Bastien Semene [mailto:bsemene@cyanide-studio.com]
>> Envoyé : mercredi 25 novembre 2009 12:12
>> À : users@httpd.apache.org
>> Objet : [users@httpd] mod_proxy configuration issue
>>
>> Hi List,
>>
>> I'm new to mod_proxy and I think my problem is really a newbie problem
>> but I didn't find the answer in the doc or Google.
>>
>> I set up a forward proxy but I can reach only web pages located on this
>> server (any vhost of this server), I can't reach web servers on the
>> local network or the Internet.
>>
>> I set up the simpliest configuration as possible for a forward proxy :
>>
>> <VirtualHost *:80>
>>         ServerAdmin admin@domain.tld
>>         ServerName proxy.domain.tld
>>
>>         ProxyRequests On
>>         ProxyVia On
>>
>>         <Proxy *>
>>                 Order deny,allow
>>                 Deny from all
>>                 Allow from a.b.c.d x.y.z.a m.n.o
>>         </Proxy>
>>
>>         ErrorLog /var/log/httpd-fproxy-error.log
>>         LogLevel Info
>>
>>         LogFormat "%v %h %l %u %t \"%r\" %>s %b" proxy_common
>>         CustomLog /var/log/httpd-fproxy-access.log proxy_common
>> </VirtualHost>
>>
>> Apache is hosting others vhosts for repositories and a reverse proxy,
>> everything works fine there when I contact them directly.
>>
>> If I try to reach "proxy.domain.tld" from a browser with this proxy
>> config, it works. I reach the default Apache page
>> (/usr/local/www/apache22/data/index.html).
>> If I try to reach another vhost on the same server, it works.
>> If I try to reach a web server on the local network it doesn't work,
>> error 503.
>> If I try to reach a web server on the Internet (Google) it doesn't work,
>> error 503.
>>
>> For pages that works I have a correct message in access.log
>> For pages that doesn't work I don't have any message nor in
>> httpd-fproxy-error.log and httpd-fproxy-access.log
>>
>> $apachectl -t is fine
>> $apachectl -S is fine
>> I can reach any webserver from the server with Lynx.
>> DNS are resolved through a local server, and resolutions are fine.
>> I have freshly installed nothing since mod_proxy was enabled for the
>> reverse proxy yet.
>>
>> I review all the directives given in the basic example from the apache
>> doc. Everything seems fine
>>
>> I'm using Apache/2.2.9 (FreeBSD) mod_ssl/2.2.9 OpenSSL/0.9.7e-p1 DAV/2
>> SVN/1.5.2 PHP/5.2.6 with Suhosin-Patch configured
>> into a FreeBSD jail from 7.2-RELEASE-p2
>>
>> Any advice or idea will be helpful,
>> Thanks,
>>
>> --
>> Bastien Semene
>> Administrateur Réseau & Système
>>
>> admin@cyanide-studio.com
>> +33 (0)1 47 86 30 80
>>
>> Cyanide S.A.
>> 5, Boulevard des Bouvets
>> 92000 Nanterre - FRANCE
>>
>>
>>     
>
> Hi,
>
> Are you using NameVirtualHost and where in your config is the snippet you included located
in the global conf file (i.e before all the others ?) ?
> It is not clear to me how you can use a forward proxy defined as a name based vhost in
your config file ... unless it's the default one (?).
> It is either not clear to me whether you did your tests in "proxy mode", i.e. defining
your Apache's proxy explicitly in your browser. 
>
> Regards.
>
> Emmanuel
>
>
>   

-- 
Bastien Semene
Administrateur Réseau & Système

admin@cyanide-studio.com
+33 (0)1 47 86 30 80

Cyanide S.A.
5, Boulevard des Bouvets
92000 Nanterre - FRANCE


Mime
View raw message