httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sandro Tosi <sandro.t...@register.it>
Subject Re: [users@httpd] LDAP: ldap_set_option failed. Could not set LDAP_OPT_X_TLS to LDAP_OPT_X_TLS_HARD
Date Mon, 02 Nov 2009 13:21:20 GMT

> I don't think that how mod_ssl was built has anything to do with your ldaps problems,
but as you could see in https://issues.apache.org/bugzilla/show_bug.cgi?id=41041 , the error
you mentioned could clearly be due to different libs used at compile time and at run time.
Maybe you could try to follow the suggestions described in this thread in order to recompile
mod_authnz_ldap with the original openssl toolkit ?
>   

I recompiled apache linking with OpenSSL 0.9.8g, and it claims it uses it:

[Mon Nov 02 13:51:47 2009] [notice] Apache/2.2.14 (Unix) mod_ssl/2.2.14 
OpenSSL/0.9.8g configured

but the problem is still there :(

The post you mention (I've already raed it) is referring to Solaris 
linker; I'm on Linux, and ld only knows of 0.9.8:

# ldconfig -p | grep -i libssl
        libssl.so.0 (libc6) => /usr/lib/libssl.so.0
        libssl.so (libc6) => /usr/lib/libssl.so

# ls -l /usr/lib/libssl.so.0
lrwxrwxrwx ... /usr/lib/libssl.so.0 -> libssl.so.0.9.8

What else can I do? Thanks a lot for the support :) ,
Sandro

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message