httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phillip Jones <pjone...@gmail.com>
Subject [users@httpd] "no handler matched request" for certain configuration
Date Tue, 29 Sep 2009 20:44:35 GMT
Hi,
I first asked about this on trac discussions, and I've been advised
that this is more likely an apache configuration issue.

In the initial setup, I've configured trac and websvn like so:
http://example.com/trac
http://example.com/websvn

relevant excerpts follow:

<Location /trac>
	SetHandler mod_python
	PythonHandler trac.web.modpython_frontend
	PythonInterpreter main
	PythonOption TracEnv /home/tracroot/project
	PythonOption TracUriRoot /trac
	SetEnv PYTHON_EGG_CACHE /tmp
</Location>

Alias /websvn /usr/share/websvn
<Directory /usr/share/websvn>
	DirectoryIndex index.php
	Options FollowSymLinks
	Order allow,deny
	Allow from all
	<IfModule mod_php4.c>
		php_flag magic_quotes_gpc Off
		php_flag track_vars On
	</IfModule>
</Directory>

In this initial setup, both trac and websvn function as expected.
However, the end goal is for trac to be at /:
http://example.com/
http://example.com/websvn

So the trac configuration is modified as follows:

<Location />
	SetHandler mod_python
	PythonHandler trac.web.modpython_frontend
	PythonInterpreter main
	PythonOption TracEnv /home/tracroot/project
	PythonOption TracUriRoot /
	SetEnv PYTHON_EGG_CACHE /tmp
</Location>

and no changes made to the websvn configuration section.

http://example.com/   -- trac works as expected
http://example.com/websvn  -- Error "No handler matched request to /websvn/"

The error message is displayed within the trac environment -- not as
an apache error page. I've experimented unsuccessfully with using
AddHandler or SetHandler directives within the websvn configuration. I
also attempted placing the alias to websvn before the <Location />
directive

Other info that might or might not be relevant:
* All the pages are https and using authentication (which I trimmed
out of the above snippets).
* Also using dav_svn for svn access on https://example.com/svn which
works in either configuration

Any advice on what to try next?
thanks

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message