httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From testwreq wreq <testw...@gmail.com>
Subject [users@httpd] .htaccess does not work
Date Thu, 10 Sep 2009 15:56:11 GMT
Hello, My goal is to password protect a few pages in one of the userdir
(/home/users/vinda). And, I cannot get this to work. Any suggestions will be
welcomed! Below is the configuration in my httpd.conf file:
<Directory /home/*/*/public_html>
Options -Indexes FollowSymLinks IncludesNoExec
Options +ExecCGI
DirectoryIndex index.html index.php index.htm
AllowOverride AuthConfig
Allow from all
Order allow,deny
AddType text/html .html
AddOutputFilter INCLUDES .html
</Directory>
I placed .htaccess in (/home/users/vinda/public_html/labs) because this is
the directory I want to protect.
Below are the contents of .htaccess and it has the .passwd file generated by
htpasswd apache command.

AuthUserFile /www/home/users/vinda/labs/.htpasswd
AuthName "Members Only"
AuthType Basic
require user lab
When I call the page with http://hostname/~vinda/labs, I get the box to
enter the username and password but then I can never pass this. The error in
the eerror log is:
[debug] mod_auth_pgsql.c(774): [client 10.105.9.103] [mod_auth_pgsql.c] -
missing configuration parameters
[Thu Sep 10 10:35:32 2009] [error] [client 10.105.9.103] access to
/~vinda/labs failed, reason: verification of user id 'lab' not configured
Please advise. Am I missing any configuration?

Thanks much:)

Mime
View raw message