httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rodrigo Aliste P." <rali...@gmail.com>
Subject [users@httpd] http problem
Date Fri, 11 Sep 2009 15:51:58 GMT
Hi

I know this is no a support forum, but I'm having troubles with Apache and I
don't know what could it be!

The problem is that sometimes the Httpd child pids start to segfault without
any reason, memory is good, cpu is good, is all good!
I've stacktraced a segfault and it shows me nothing. The only thing I get is
rt_sigaction(SIGSEGV, {SIG_DFL, [], SA_INTERRUPT}, {SIG_DFL, [],
SA_RESETHAND}, 8) = 0. I'm running the httpd under gdb to get more readable
detail when segfaults again. And I'll post the result here.

Any ideas?


The machine is a HP Proliant DL 320 G5 with Intel Xeon X3320 and 2GB Ram
with Centos 5 i386.
PHP 5.2.5 with Xcache
Mysql 5.0.45 (php-mysql api versions match)
Apache 2.2.3

# httpd -V
Server version: Apache/2.2.3
Server built:   Jul 14 2009 06:04:04
Server's Module Magic Number: 20051115:3
Server loaded:  APR 1.2.7, APR-Util 1.2.7
Compiled using: APR 1.2.7, APR-Util 1.2.7
Architecture:   32-bit
Server MPM:     Prefork
  threaded:     no
    forked:     yes (variable process count)
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=128
 -D HTTPD_ROOT="/etc/httpd"
 -D SUEXEC_BIN="/usr/sbin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

Loaded modules are http://pastebin.ca/1562241
-- 
Rodrigo Aliste P.

Mime
View raw message