httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin J. Woolley" <kev...@activestate.com>
Subject Re: [users@httpd] ProxyPass gets "stuck" in a VirtualHost
Date Wed, 16 Sep 2009 20:36:51 GMT
Nick Kew wrote:

>> I have a collection of machines with identical installations of 
>> Apache, each with a couple of dozen VirtualHosts.  The specific 
>> problem I'm facing is that there is one VirtualHost (vhosta) that 
>> needs to ProxyPass to another VirtualHost, which I'm doing like this:
>>
>>     ProxyPass /catalog https://vhostb.activestate.com/json/catalog
>>     ProxyPassReverse /catalog https://vhostb.activestate.com/json/catalog
> 
> That's a very strange thing to be doing on a single host.
> Why not just alias it?

I hadn't tried it -- vhostb is running a PHP application framework, 
while vhosta is completely static and uses no PHP.  I'll likely wind up 
giving aliasing a shot.

>> This is in an SSL-enabled vhost, needless to say.
>>
>> The effect it's having is that I get a 404 and an entry in vhosta's 
>> error_log that it can't find /path/to/vhosta/htdocs/json/catalog.
> 
> At a guess, something in your toolchain doesn't support SNI.

Yup -- using CentOS 5.3's Apache 2.2.3, which Wikipedia's SNI article 
says is about nine points behind SNI support.  That's almost certainly 
the culprit.

Thank you for your help, Nick -- greatly appreciated!

Cheers,

kjw


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message