httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: [users@httpd] ProxyPass gets "stuck" in a VirtualHost
Date Wed, 16 Sep 2009 20:31:28 GMT
Kevin J. Woolley wrote:
> Hello folks,
> 
> I'm running into an odd problem, and I'm just about at the point of RTFS 
> for it, but I'm hoping that someone can lend a hand.
> 
> I have a collection of machines with identical installations of Apache, 
> each with a couple of dozen VirtualHosts.  The specific problem I'm 
> facing is that there is one VirtualHost (vhosta) that needs to ProxyPass 
> to another VirtualHost, which I'm doing like this:
> 
>     ProxyPass /catalog https://vhostb.activestate.com/json/catalog
>     ProxyPassReverse /catalog https://vhostb.activestate.com/json/catalog

That's a very strange thing to be doing on a single host.
Why not just alias it?

> This is in an SSL-enabled vhost, needless to say.
> 
> The effect it's having is that I get a 404 and an entry in vhosta's 
> error_log that it can't find /path/to/vhosta/htdocs/json/catalog.

At a guess, something in your toolchain doesn't support SNI.

-- 
Nick Kew

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message