httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clive Kinton <mailbacku...@googlemail.com>
Subject [users@httpd] OT: Vista Xampp and 'allow from localhost'
Date Wed, 30 Sep 2009 19:47:45 GMT
Has anybody run into some weirdness with Apache 2.2.12 from Xampp on
Vista and ip to hostname resolution for 'localhost'? The httpd.conf is
vanilla, as shipped.

Specific issue: Trying to limit access to a directory with a
simple .htaccess file like:

Order deny,allow
Deny from all
Allow from localhost
Allow from 127.0.0.1

or even

Order allow,deny
Allow from localhost
Allow from 127.0.0.1

>>From the localhost calling the protected directory thus:
http://127.0.0.1/protected

Works - but -
http://localhost/protected
does not and 403's

A similar Linux box running apache on the same network does not do this,
leading me to think there is some kind of weirdness going on with how
Vista resolves IP to hostname.

I've done the obvious things I can think of (hosts/lmhosts) but there is
a gap in my understanding of where Vista will look to resolve
'localhost'. An entry in hosts does not seem sufficient.

Any pointers gratefully received. I know this is OT, but perhaps someone
has come across this?


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message