httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Cicimov <icici...@gmail.com>
Subject Re: [users@httpd] Trouble compiling apache with mod_ssl, having two versions of OpenSSL on openSUSE 10.3
Date Sun, 09 Aug 2009 07:33:24 GMT
Did you read the README and INSTALL files in the OpenSSL folder (I assume
you have openssl tarball downloaded)? They usually explain what and how to
use in the ./configure and make commands. Read the help pages for configure
and make too.

On Sat, Aug 8, 2009 at 11:17 AM, Dan Stromberg <dstromberglists@gmail.com>wrote:

> The subject line summarizes the issue pretty well.  Following are the
> details:
>
> The problem stems, of course, from the new packages I'm building on an
> old OS.  I don't have much choice in the matter though - these are the
> constraints I must operate within.
>
> I want to have two versions of OpenSSL on the system in question - one
> that comes with OS, and one for a new apache and subversion.
>
> I've tried both with OpenSSL 0.9.8k and OpenSSL 1.0.0 beta 3.  This
> message will cover the specifics of the situation with 1.0.0 beta 3.
>
> I'm using the following small script to configure and build against
> OpenSSL 1.0.0 beta 3:
>
>   export PATH=/usr/local/svn/bin:$PATH
>   CC="gcc -I/usr/local/svn/include -L/usr/local/svn/lib -Wl,-rpath
> -Wl,/usr/local/svn/lib" ./configure --prefix=/usr/local/svn
> --enable-modules=all --enable-ssl --with-ssl=/usr/local/svn && make -j
> 1
>
> With this script in place, the apache build chugs along for a while,
> and then gives copious errors starting with:
>
>   make[3]: Entering directory
> `/data/swbuild/da_build/src/apache2/src/modules/ssl'
>   /usr/local/svn/build-1/libtool --silent --mode=compile gcc
> -I/usr/local/svn/include -L/usr/local/svn/lib -Wl,-rpath
> -Wl,/usr/local/svn/lib -g -O2 -pthread    -DLINUX=2 -D_REENTRANT
> -D_GNU_SOURCE
>      -I/data/swbuild/da_build/src/apache2/src/srclib/pcre -I.
> -I/data/swbuild/da_build/src/apache2/src/os/unix
> -I/data/swbuild/da_build/src/apache2/src/server/mpm/prefork
>      -I/data/swbuild/da_build/src/apache2/src/modules/http
> -I/data/swbuild/da_build/src/apache2/src/modules/filters
> -I/data/swbuild/da_build/src/apache2/src/modules/proxy
>      -I/data/swbuild/da_build/src/apache2/src/include
> -I/data/swbuild/da_build/src/apache2/src/modules/generators
> -I/data/swbuild/da_build/src/apache2/src/modules/mappers
>      -I/data/swbuild/da_build/src/apache2/src/modules/database
> -I/usr/local/svn/include/apr-1
> -I/data/swbuild/da_build/src/apache2/src/server
> -I/data/swbuild/da_build/src/apache2/src/modules/proxy/../generators
>      -I/usr/local/svn/include
> -I/data/swbuild/da_build/src/apache2/src/modules/ssl
> -I/data/swbuild/da_build/src/apache2/src/modules/dav/main
> -prefer-non-pic -static -c mod_ssl.c && touch mod_ssl.lo
>   In file included from ssl_private.h:60,
>                    from mod_ssl.c:27:
>   ssl_toolkit_compat.h:254:2: error: #error "Unrecognized SSL Toolkit!"
>   In file included from ssl_private.h:62,
>                    from mod_ssl.c:27:
>   ssl_util_ssl.h:78: error: expected ‘)’ before ‘*’ token
>   ssl_util_ssl.h:79: error: expected ‘)’ before ‘*’ token
>
> The key part seeming to #error "Unrecognized SSL Toolkit".
>
> Line 254 of ssl_toolkit_compat.h is (and is surrounded by):
>
>   #else /** ! HAVE_OPENSSL && ! HAVE_SSLC */
>
>   #error "Unrecognized SSL Toolkit!"
>
>   #endif /* ! HAVE_OPENSSL && ! HAVE_SSLC */
>
> IOW, it appears thtat HAVE_OPENSSL isn't defined, even though I have
> 1.5 versions (I mv'd /usr/include/openssl to
> /usr/include/openssl.nopers) on the system.  Also,
> include/ap_config_auto.h have HAVE_OPENSSL #define'd to 1.
>
> But if I cut and paste the libtool command for compiling mod_ssl.c,
> addnig a -E to it to get just the cpp output, it appears that
> ap_config_auto.h isn't getting #include'd.
>
> Something's clearly going wrong with the build.  Maybe it's because
> I'm doing something a little bit hackish setting that weird $CC,
> though that's worked well for me in the past.
>
> What do I need to do to build the latest apache aganist the latest
> OpenSSL on openSUSE 10.3?
>
> Thanks!
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

Mime
View raw message