httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Cicimov <icici...@gmail.com>
Subject [users@httpd] Re: libapr problem after moving apache to chroot
Date Mon, 03 Aug 2009 05:21:59 GMT
Sorry forgot to mention that the built is on Solaris 9.



On Mon, Aug 3, 2009 at 3:19 PM, Igor Cicimov <icicimov@gmail.com> wrote:

> Hi all,
>
> I have this strange behavior with the new apache 2.2.12 I just built. I
> compiled it and install in the /usr/local/apache2 directory and all was
> fine, I could start and stop the server no errors. But after moving the
> server to /chroot/usr/local/apache2 I get the problem bellow:
>
> # ldd /chroot/usr/local/apache2/bin/httpd
>
>         libm.so.1 =>     /usr/lib/libm.so.1
>         libaprutil-1.so.0 =>     (file not found)
>         libexpat.so.0 =>         /usr/local/apache2/lib/libexpat.so.0
>         libapr-1.so.0 =>         (file not found)
>         libuuid.so.1 =>  /usr/lib/libuuid.so.1
>         libsendfile.so.1 =>      /usr/lib/libsendfile.so.1
>         librt.so.1 =>    /usr/lib/librt.so.1
>         libsocket.so.1 =>        /usr/lib/libsocket.so.1
>         libnsl.so.1 =>   /usr/lib/libnsl.so.1
>         libpthread.so.1 =>       /usr/lib/libpthread.so.1
>         libdl.so.1 =>    /usr/lib/libdl.so.1
>         libc.so.1 =>     /usr/lib/libc.so.1
>         libgcc_s.so.1 =>         /usr/lib/libgcc_s.so.1
>         libaio.so.1 =>   /usr/lib/libaio.so.1
>         libmd5.so.1 =>   /usr/lib/libmd5.so.1
>         libmp.so.2 =>    /usr/lib/libmp.so.2
>         libthread.so.1 =>        /usr/lib/libthread.so.1
>         /usr/platform/SUNW,Sun-Fire-V240/lib/libc_psr.so.1
>         /usr/platform/SUNW,Sun-Fire-V240/lib/libmd5_psr.so.1
>
> So looks like the server can't find he's own built in libapr-1.so.0 and
> libaprutil-1.so.0 libraries but I can see they exist in the lib folder:
>
> # ls -l /chroot/usr/local/apache2/lib/
> total 21872
> -rw-r--r--   1 root     other       8130 Aug  3 14:23 apr.exp
> -rw-r--r--   1 root     other       5147 Aug  3 14:23 aprutil.exp
> -rw-r--r--   1 root     other    3402880 Aug  3 14:23 libapr-1.a
> -rwxr-xr-x   1 root     other        860 Aug  3 14:23 libapr-1.la
> lrwxrwxrwx   1 root     other         17 Aug  3 14:40 libapr-1.so ->
> libapr-1.so.0.3.7
> lrwxrwxrwx   1 root     other         17 Aug  3 14:40 libapr-1.so.0 ->
> libapr-1.so.0.3.7
> -rwxr-xr-x   1 root     other    3344852 Aug  3 14:23 libapr-1.so.0.3.7
> -rw-r--r--   1 root     other    1867096 Aug  3 14:23 libaprutil-1.a
> -rwxr-xr-x   1 root     other        958 Aug  3 14:23 libaprutil-1.la
> lrwxrwxrwx   1 root     other         21 Aug  3 14:40 libaprutil-1.so ->
> libaprutil-1.so.0.3.8
> lrwxrwxrwx   1 root     other         21 Aug  3 14:40 libaprutil-1.so.0 ->
> libaprutil-1.so.0.3.8
> -rwxr-xr-x   1 root     other    1834092 Aug  3 14:23 libaprutil-1.so.0.3.8
> -rw-r--r--   1 root     other     349608 Aug  3 14:23 libexpat.a
> -rwxr-xr-x   1 root     other        807 Aug  3 14:23 libexpat.la
> lrwxrwxrwx   1 root     other         17 Aug  3 14:40 libexpat.so ->
> libexpat.so.0.1.0
> lrwxrwxrwx   1 root     other         17 Aug  3 14:40 libexpat.so.0 ->
> libexpat.so.0.1.0
> -rwxr-xr-x   1 root     other     305532 Aug  3 14:23 libexpat.so.0.1.0
> drwxr-xr-x   2 root     other        512 Aug  3 14:23 pkgconfig
>
>
> Any idea what went wrong and why is only libapr not found by the server?
>
> Thanks in advance for any help.
>
>

Mime
View raw message