httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Todd Nine <todd.n...@gmail.com>
Subject [users@httpd] Help with http proxy and not escaping characters
Date Wed, 26 Aug 2009 03:18:34 GMT
Hi all,
  I'm using Apache 2.2.3 on CentOS 5.3 to proxy a connection to a splunk
installation.  I use Apache for http redirection and handling the SSL
communication.  Here is my /etc/rc.d/splunk.conf file.

ProxyRequests Off
ProxyPreserveHost On


<Proxy *>
Order deny,allow
Allow from all
</Proxy>

RewriteMap unescape int:unescape
RewriteEngine On
RewriteRule ^/(.*)$ http://localhost:8080/${unescape:$1} [P]


ProxyPass / http://localhost:8080/
ProxyPassReverse / http://localhost:8080/

<Location />
        Order allow,deny
        Allow from all
</Location>


Basically something is wrong with the HTML that's being returned.  If I hit
the server directly via port 8080, a href in an anchor tag will have this
value.

/en-US/app/search/@go?s=AFF - Feed Online

However if I use the proxy connection, I get this in the href

/en-US/app/search/@go?s=AFF%20-%20Feed%20Online

How can I tell the http proxy to not escape data coming from the target
splunk python server on port 8080?  I tried some rewrite rules according to
some examples to unescape urls coming in as a workaround, but I'm not
getting what I need as the escaped characters are getting passed to splunk.
Any help would be greatly appreciated.

Thanks,
Todd

Mime
View raw message