httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sushant Gulati <sushant...@gmail.com>
Subject Re: [users@httpd] Re: Apache load balancing
Date Fri, 14 Aug 2009 11:19:51 GMT
Please try to use the jvmRoute directive in the server.xml.

Regards,
Sushant


On Fri, Aug 14, 2009 at 3:58 PM, nilesh p <nilesh.pj@gmail.com> wrote:

>
> wprker.properties is shown below
> ****************************************************
> worker.list=loadbalancer
>
>
> worker.loadbalancer.type=lb
> worker.loadbalancer.balance_workers=server2,server3,server4
> worker.loadbalancer.sticky_session=true
>
>
>
>
> # Set properties for worker 'server2' (ajp13)
> worker.server2.type=ajp13
> worker.server2.host=ip2
> worker.server2.port=8009
>
> worker.server2.cachesize=10
> worker.server2.cache_timeout=600
> worker.server2.socket_keepalive=1
> worker.server2.reclycle_timeout=300
>
> # Set properties for worker 'server3' (ajp13)
> worker.server3.type=ajp13
> worker.server3.host=ip3
> worker.server3.port=8009
>
> worker.server3.cachesize=10
> worker.server3.cache_timeout=600
> worker.server3.socket_keepalive=1
> worker.server3.reclycle_timeout=300
>
> # Set properties for worker 'server4' (ajp13)
> worker.server4.type=ajp13
> worker.server4.host=ip4
> worker.server4.port=8009
>
> worker.server4.cachesize=10
> worker.server4.cache_timeout=600
> worker.server4.socket_keepalive=1
> worker.server4.reclycle_timeout=300
>
> *******************************************************************
>
> Also my jboss server.xml does NOT have an entry for <jvmroute=server1/2>
> Is it necessary? because i have seen through jboss web console that
> connections are being made to the second server
>
> PS: server 2 is shutdown, so server3 and server4 are the 2 jboss servers
>
>
>
>
>
>
>
>
>
>
>
>
>
> nilesh p wrote:
> >
> > Dear Friends,
> >
> > Using apache i am trying to load balance JBOSS.There are 2 JBOSS
> instances
> > on 2 different servers.Now if only one JBOSS is started , the application
> > works perfectly. However, when i start the other JBOSS, my application
> > starts giving "service temporarily unavailable" or "session expired"
> > errors intermittently.
> >
> > Both the JBOSS instances are exact replicas listening on same AJP port
> > 8009 and HTTP port 8080.
> >
> > Also if the application is accessed by directly connecting to the JBOSS
> > instances, then it works normal.Only through APACHE i get this error. Is
> > there some load balancing issue? Has anybody faced such an issue???
> >
> > Regards,
> > Nilesh
> >
>
> --
> View this message in context:
> http://www.nabble.com/Apache-load-balancing-tp24969245p24969559.html
>  Sent from the Apache HTTP Server - Users mailing list archive at
> Nabble.com.
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

Mime
View raw message