httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From apache-u...@herveybayaustralia.com.au
Subject [users@httpd] Apache dies in Freebsd jail
Date Wed, 05 Aug 2009 04:02:46 GMT
I know this sounds like a headline, but its true.

I had a disk space problem in the jail, so I reconfigured and restored the apache on the new
disk size. I then added my other modules that I required from ports. I then checked if it
all worked, and I got nada- firefox tells me the sites valid but the server won't connect.

So far I've tried upping log levels to debug, httpd -X, and running portupgrade -fRr apache.
All to no avail- I can get no message or hint or idea of why apache fails. If I run ps -ax
I see httpd -DNOHTTPACCEPT or httpd -X still running (apparently), but I can't see any listeners
on any ports/interfaces with sockstat.

I need some help debugging this- something (ANYTHING!) that will give me a clue on what I've
missed here. I'd rather not just blow it all away without attempting to find out what the
hell is behind this.

I'm running a jailed FreeBSD 7.2 and apache-2.2.11_7 built from ports. I've built php5-5.2.10,
mod_perl2-2.0.4_2,3, and mod_python-3.3.1_2 all from ports as well. I've tried the freebsd-questions
list, but I haven't got a response or seen my message even get through.

Any clues will be much appreciated. My logs aren't giving me anything, only that all the modules
are all loading ok. I had some ssl cache warnings, but they're resolved (I think). I believe
it can't bind to the network for some reason: I need to find that reason.... :)

Cheers


---- Msg sent via @Mail - http://atmail.com/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message