httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Petteri Heinonen <petteri.j.heino...@kolumbus.fi>
Subject [users@httpd] apache 2.2 / mod_proxy / parameters
Date Fri, 21 Aug 2009 09:59:40 GMT
Hello list users.

I'm struggling with mod_proxy parameters related to amount of open connections to backend
etc. Here is an excerpt of my configuration:

 ProxyPass /exchange/ https://exchange.company.com/exchange/ min=10 max=32 acquire=10000 keepalive=on
retry=5 timeout=15
 ProxyPassReverse /exchange/ https://exchange.company.com/exchange/
 ProxyPass /exchweb/ https://exchange.company.com/exchweb/ min=10 max=32 acquire=10000 keepalive=on
retry=5 timeout=15
 ProxyPassReverse /exchweb/ https://exchange.company.com/exchweb/
 ProxyPass /public/ https://exchange.company.com/public/ min=10 max=32 acquire=10000 keepalive=on
retry=5 timeout=15
 ProxyPassReverse /public/ https://exchange.company.com/public/
 ProxyPass /iisadmpwd/ https://exchange.company.com/iisadmpwd/ min=10 max=32 acquire=10000
keepalive=on retry=5 timeout=15
 ProxyPassReverse /iisadmpwd/ https://exchange.company.com/iisadmpwd/

As you can see, what I'm trying to achieve is a webmail proxy for our company's Exchange server.
This problem is not tied to Exchange however, I'm experiencing the problem described below
no matter what server is used a a backend.

First of all, min parameter seems not have any effect. When I start Apache, 10 connections
are not opened to backend immediately. From documentation:

min: Minimum number of connections that will always be open to the backend server.

>From that, I would conclude that it should keep 10 connections always opened, no matter
what. However, using netstat -atpn I can see that connections are not opened always, but instead
only during activity from the clients.

Second problem is keepalive. From documentation, I understand that this parameter should cause
connections once opened to be kept open. This seems not to be case; after activity, connections
are kept open for some time, but no keepalives are sent. I have verified this using wireshark.
As a result, backend server soon resets the connections, and they have to be opened again
upon new activity.

I have also notices the same behavior with both prefork and worker mpm's. Currently prefork
mpm is in use:

    StartServers         10
    MinSpareServers      10
    MaxSpareServers      20
    MaxClients          256
    MaxRequestsPerChild   0

I'm starting to think that I have understood something completely wrong here. I would be thankful
of any hint about what might be going on here.

Regards, Petteri Heinonen

-- 



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message