httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Headley <raider...@gmail.com>
Subject [users@httpd] Apache APR Crash with Trac
Date Tue, 09 Jun 2009 20:23:43 GMT
I've attempted to work this issue through the Trac mailing list, but it now
appears to be an issue with the Apache APR library.  Here's the background:

Configuration:
 Apache 2.2.11 with mod_wsgi
 Windows Small Business Server 2008
 Trac 0.11.4
 SVN 1.5.6 (r36142)
 Python 2.5.4

I'm installing Trac for the first time on this server, and am having issues
with Trac connecting to the SVN repository.  SVN has been running well for
several weeks behind the Apache HTTP Server.  I believe I have the Trac
environment established successfully, and can connect to Trac via Apache
using the mod_wsgi approach with the repository_dir cleared.

With my Trac.ini file set with the following I can view the generic "Welcome
to Trac" page and local documentation:
  repository_dir =
  repository_type = svn

When I change it to
    repository_dir = c:\svn\ltm
the Trac URL is no longer accessible and I get a "Connection Interrupted.
The connection to the server was reset while the page was loading." in the
browser.

With the repository_dir set with the correct path, I can run trac-admin
resync and the repository history counts through all 292 revisions
successfully.  This leads me to believe that the connection to SVN is
established properly from Trac, but I still can't view anything through a
browser with the repository path included.

Thinking it may be a rights issue, I tried to run Apache as an application
(with Run As Administrator) instead of a service, and noticed that the app
crashes when I go to the Trac URL from a remote browser.  I went back into
the Windows Event Viewer and the Apache service crashes every time I try to
connect to Trac:

Faulting application httpd.exe, version 2.2.11.0, time stamp 0x493f5d44,
faulting module libapr.dll, version 0.9.17.0, time stamp 0x4878c068,
exception code 0xc0000005, fault offset 0x000139c1, process id 0x15d8,
application start time 0x01c9e495a599432c.


I changed the HTTPD logging level to DEBUG in order to get more information,
and it didn't reveal very much:

[Tue Jun 09 13:01:25 2009] [info] [client 192.168.25.100] mod_wsgi
(pid=1384, process='', application=''): Loading WSGI script
'C:/SVN/trac/test/apache/trac.wsgi'.
[Tue Jun 09 13:01:28 2009] [notice] Parent: child process exited with status
255 -- Restarting.
[Tue Jun 09 13:01:28 2009] [warn] mod_wsgi: Compiled for Python/2.5.
[Tue Jun 09 13:01:28 2009] [warn] mod_wsgi: Runtime using Python/2.5.4.
[Tue Jun 09 13:01:28 2009] [warn] mod_wsgi: Python module path
'C:\\Windows\\system32\\python25.zip;C:\\Python25\\Lib;C:\\Python25\\DLLs;C:\\Python25\\Lib\\lib-tk;;C:\\Program
Files (x86)\\Apache Software Foundation\\Apache2.2\\bin'.
[Tue Jun 09 13:01:28 2009] [info] mod_wsgi: Initializing Python.
[Tue Jun 09 13:01:28 2009] [notice] Apache/2.2.11 (Win32) SVN/1.5.6
mod_wsgi/2.3 Python/2.5.4 DAV/2 configured -- resuming normal operations
...

The trac.wsgi file is pretty simple:
import os

def application(environ, start_request):
    if not 'trac.env_path_parent_dir' in environ:
        environ.setdefault('trac.env_path', 'c:\\svn\\trac\\test')
    if 'PYTHON_EGG_CACHE' in
environ:
        os.environ['PYTHON_EGG_CACHE'] = environ['PYTHON_EGG_CACHE']
    elif 'trac.env_path' in environ:
        os.environ['PYTHON_EGG_CACHE'] =
os.path.join(environ['trac.env_path'],
                                                      '.egg-cache')
    elif 'trac.env_path_parent_dir' in environ:
        os.environ['PYTHON_EGG_CACHE'] =
os.path.join(environ['trac.env_path_parent_dir'],
                                                      '.egg-cache')
    from trac.web.main import dispatch_request
    return dispatch_request(environ, start_request)


Other things I've tried:
Turned off UAC - no change in behavior
Changed the path variables a number of different ways using //, \\, /, \,
..\..\, etc - no change


Anyone have an idea of what to try next?

Thanks,
Dave

Mime
View raw message