httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Vaughan" <david.vaug...@satemail.com>
Subject [users@httpd] ProxyBlock
Date Thu, 18 Jun 2009 13:50:29 GMT
Hi there.

I have been experimenting with the ProxyBlock directive when running
Apache 2.2 as a forward proxy.

When Apache is the final proxy in a chain, everything works as expected.
However if I configure Apache to chain requests to another proxy (using
ProxyRemote * http://next_proxy.com:8080), then the ProxyBlock directive
ceases to operate correctly.  Under these circumstances ProxyBlock *
works as expected but all other forms appear to have no effect, although
observed DNS requests during Apache startup seem to indicate the
directive is recognised.  ProxyBlock is defined in the context of a
virtual host.

I have found a couple of posts that talk about the interaction of
ProxyRemote and ProxyBlock in relation to address resolution, but these
date back to Apache 2.0 & 2.1 (2005).  


Can anyone explain the observed behaviour?


Many thanks
Dave


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message