httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: [users@httpd] Apr_bucket_read() failed when uploading files
Date Mon, 22 Jun 2009 18:14:26 GMT
André Warnier wrote:
...
> 
> How exactly is this data being POSTed by the browser ?  via a standard 
> POST of an html <form>, or via some Ajax/javascript/java code or the like ?
> 
Ok, I tested that myself, using the page you provided, which is a 
straight html form, nothing wrong with it.
I uploaded an 800 KB file for testing.
I don't see anything wrong, except for the fact that the server responds 
  "200 OK", but the result html page shows a message "wrong input" (in 
the html content of that page).
But then, that is the output of your cgi script, and I don't know what 
that one does.
As far as I can tell, there is no error during the upload of the file. 
There might be one when you later process it with the script though.

Do I need to test with a larger file, to see the error ?
Can you post the content of your "test.pl" script ?


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message