httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Oliver <joli...@john-oliver.net>
Subject Re: [users@httpd] https works, http doesn't
Date Mon, 01 Jun 2009 22:54:34 GMT
On Mon, Jun 01, 2009 at 06:27:35PM -0400, Frank Gingras wrote:
> John,
> 
> Then you are looking in the wrong error log, since a 403 is always logged.
> 
> The other possibility is that you're hitting browser cache.

There are no other log files.

[root@mda-vm1h ~]# date
Mon Jun  1 15:46:53 PDT 2009
[root@mda-vm1h ~]# ls -l /var/log/httpd/ | grep "Jun  1"
-rw-r--r-- 1 root root      8927 Jun  1 15:46 access_log
-rw-r--r-- 1 root root     13210 Jun  1 15:46 error_log
-rw-r--r-- 1 root root      3527 Jun  1 15:43 ssl_access_log
-rw-r--r-- 1 root root       637 Jun  1 14:45 ssl_error_log
-rw-r--r-- 1 root root      3979 Jun  1 15:43 ssl_request_log
[root@mda-vm1h ~]# tail /var/log/httpd/error_log
[Mon Jun 01 15:21:52 2009] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Mon Jun 01 15:21:53 2009] [notice] Digest: generating secret for digest
authentication ...
[Mon Jun 01 15:21:53 2009] [notice] Digest: done
[Mon Jun 01 15:21:53 2009] [notice] Apache/2.2.3 (Red Hat) configured --
resuming normal operations
[Mon Jun 01 15:46:13 2009] [notice] caught SIGTERM, shutting down
[Mon Jun 01 15:46:14 2009] [notice] SELinux policy enabled; httpd
running as context user_u:system_r:httpd_t:s0
[Mon Jun 01 15:46:14 2009] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Mon Jun 01 15:46:14 2009] [notice] Digest: generating secret for digest
authentication ...
[Mon Jun 01 15:46:14 2009] [notice] Digest: done
[Mon Jun 01 15:46:14 2009] [notice] Apache/2.2.3 (Red Hat) configured --
resuming normal operations


And I'm using shift-refresh, so it isn't likely to be browser cache.

Unless httpd is writing the logged 403s to somewhere else.  Not sure how
that could be,a s I have:

ErrorLog logs/error_log

And maybe it isn't a 403?  Browser just says:

Forbidden

You don't have permission to access /index.html on this server.

-- 
***********************************************************************
* John Oliver                             http://www.john-oliver.net/ *
*                                                                     *
***********************************************************************

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message