httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Covener <cove...@gmail.com>
Subject Re: [users@httpd] Apr_bucket_read() failed when uploading files
Date Mon, 22 Jun 2009 17:10:13 GMT
On Mon, Jun 22, 2009 at 12:59 PM, Mark<asarian@xs4all.nl> wrote:
> -----Original Message-----
> From: Eric Covener [mailto:covener@gmail.com]
> Sent: maandag 22 juni 2009 18:33
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] Apr_bucket_read() failed when uploading files
>
>> The bug talks about uploading to a script that doesn't read the POST
>> body. Aren't you reading it to do something with it?  Are you sure you're
>> reading all of it?
>
> The problem is, that you don't even get to where you can read/do anything
> with the POST data. When I test it, either one of two things happen:
> either browser suddenly disconnects. or CGI.pm fails eval, and cannot be
> loaded (the presence of POST data apparently causes Apache to fail its
> init under these circumstances). The "apr_bucket_read() failed" is the
> only thing Apache logs for it.

Doesn't sound likely to be the same issue as in the referenced
bugzilla (client is busy writing, never gets around to reading
response.

 Maybe the client gives up for another reason?  A packet capture is
probably the next step.


-- 
Eric Covener
covener@gmail.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message