httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [users@httpd] Issue w/ Apache httpd 2.2.11 in Windows Vista
Date Wed, 27 May 2009 23:27:11 GMT
kowa@redshift.com wrote:
>> kowa@redshift.com wrote:
>>> I installed Apache as a service as normal, then tried to run it.  It
>>> ran...but it won't read the httpd.conf file.  Even changing the
>>> service to call httpd.exe -k runservice -f (path to conf file) *does
>>> not work*.  I can only run httpd manually, from the command prompt,
>>> with the -f parameter, and get it to read the conf file.
>>>
>>> Why???
>> Not enough info for anyone to give you an answer.  Some thoughts; don't
>> mess with the HKLM\Services key ever, always use httpd.exe -k config.
> 
> httpd.exe -k config output:
> 
> C:\Program Files\Apache Software Foundation\Apache2.2\bin>httpd.exe -k config
> Reconfiguring the Apache2.2 service
> The Apache2.2 service is successfully installed.
> Testing httpd.conf....
> Errors reported here must be corrected before the service can be started.

defaults to;
 C:\Program Files\Apache Software Foundation\Apache2.2\conf\httpd.conf

you moved httpd.conf?  Then you must

httpd.exe -k config -d ServerRootDir -f PathTohttpd.conf

> In httpd.conf, I have the document root pointing to a different folder, so
> that's how I know it's not reading httpd.conf.

on the local drive or on the network?


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message