httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abel Braaksma <abel.onl...@xs4all.nl>
Subject Re: [users@httpd] After restart Vista, working Apache 2.2.11 stopped working, reinstall, google, etc to no avail
Date Fri, 15 May 2009 19:30:36 GMT
I tried finding any corresponding httpd.exe and any other Apache entries 
in registry, but none were found. I tried WinDbg with the symbol files, 
but since I don't (yet) have a compilable installation of Apache, I'm 
not sure if this makes any sense. To me it doesn't. It errors out early 
(much earlier then in a normal run) and I don't seem to be able to jump 
over (must say, I am more of a Visual Studio guy then a WindDbg guy).

Anyway, just in the event that this makes more sense to you then it does 
to me, and in the event that you still want to spend some time on this 
issue, here's the output from starting Apache + symbols from WinDbg:

CommandLine: "C:\Program Files\Apache Software 
Foundation\Apache2.2\bin\httpd.exe" -k start -l debug
Symbol search path is: C:\Program Files\Apache Software 
Foundation\Apache2.2\bin;C:\Program Files\Apache Software 
Foundation\Apache2.2\modules
Executable search path is:
ModLoad: 00400000 00406000   httpd.exe
ModLoad: 77660000 77787000   ntdll.dll
ModLoad: 76070000 7614b000   C:\Windows\system32\kernel32.dll
ModLoad: 6eec0000 6eee1000   C:\Program Files\Apache Software 
Foundation\Apache2.2\bin\libapr-1.dll
ModLoad: 76180000 76246000   C:\Windows\system32\ADVAPI32.dll
ModLoad: 76490000 76552000   C:\Windows\system32\RPCRT4.dll
ModLoad: 76410000 7643d000   C:\Windows\system32\WS2_32.dll
ModLoad: 77810000 778ba000   C:\Windows\system32\msvcrt.dll
ModLoad: 77790000 77796000   C:\Windows\system32\NSI.dll
ModLoad: 75550000 7558b000   C:\Windows\system32\MSWSOCK.dll
ModLoad: 76a00000 77510000   C:\Windows\system32\SHELL32.dll
ModLoad: 767f0000 7683b000   C:\Windows\system32\GDI32.dll
ModLoad: 76560000 765fd000   C:\Windows\system32\USER32.dll
ModLoad: 76600000 76658000   C:\Windows\system32\SHLWAPI.dll
ModLoad: 6ee60000 6ee8f000   C:\Program Files\Apache Software 
Foundation\Apache2.2\bin\libaprutil-1.dll
ModLoad: 6ee50000 6ee59000   C:\Program Files\Apache Software 
Foundation\Apache2.2\bin\libapriconv-1.dll
ModLoad: 6ff00000 6ff48000   C:\Program Files\Apache Software 
Foundation\Apache2.2\bin\libhttpd.dll
(174c.13a8): Break instruction exception - code 80000003 (first chance)
eax=00000000 ebx=00000000 ecx=0006fb08 edx=776b9a94 esi=fffffffe 
edi=776bb6f8
eip=776a7dfe esp=0006fb20 ebp=0006fb50 iopl=0         nv up ei pl zr na 
pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             
efl=00000246
*** ERROR: Symbol file could not be found.  Defaulted to export symbols 
for ntdll.dll -
ntdll!DbgBreakPoint:
776a7dfe cc              int     3
0:000> g
ModLoad: 76320000 7633e000   C:\Windows\system32\IMM32.DLL
ModLoad: 76340000 76408000   C:\Windows\system32\MSCTF.dll
ModLoad: 777a0000 777a9000   C:\Windows\system32\LPK.DLL
ModLoad: 766e0000 7675d000   C:\Windows\system32\USP10.dll
ModLoad: 74e30000 74fce000   
C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.6001.18000_none_5cdbaa5a083979cc\comctl32.dll
ModLoad: 10000000 10027000   C:\Windows\system32\guard32.dll
ModLoad: 77510000 77654000   C:\Windows\system32\ole32.dll
ModLoad: 75d60000 75d68000   C:\Windows\system32\VERSION.dll
ModLoad: 75d50000 75d57000   C:\Windows\system32\fltlib.dll
(174c.13a8): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=00966f90 ebx=0000002b ecx=0000002b edx=00969001 esi=00969001 
edi=00966f18
eip=6eec9f0d esp=0006fe58 ebp=0006fe68 iopl=0         nv up ei pl nz ac 
po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             
efl=00010212
*** WARNING: Unable to verify checksum for C:\Program Files\Apache 
Software Foundation\Apache2.2\bin\libapr-1.dll
libapr_1!warrsztoastr+0x9d:
6eec9f0d 8a16            mov     dl,byte ptr [esi]          
ds:0023:00969001=??
0:000> g
(174c.13a8): Access violation - code c0000005 (!!! second chance !!!)
eax=00966f90 ebx=0000002b ecx=0000002b edx=00969001 esi=00969001 
edi=00966f18
eip=6eec9f0d esp=0006fe58 ebp=0006fe68 iopl=0         nv up ei pl nz ac 
po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             
efl=00010212
libapr_1!warrsztoastr+0x9d:
6eec9f0d 8a16            mov     dl,byte ptr [esi]          
ds:0023:00969001=??




William A. Rowe, Jr. wrote:
> Abel Braaksma wrote:
>   
>> maybe I should install the debugging environment after all, to see what
>> passes through there
>>     
>
> All you should need are to extract the -symbols.zip .pdb files and use good
> old windbg.
>
>   
>>> Corrupted service?  Might have to uninstall the service, reboot, then
>>> manually delete this key;
>>> HKLM\System\CurrentControlSet\Services\[service name]
>>> and reinstall the service.
>>>   
>>>       
>> If you mean the Apache service: it has been removed a couple of times,
>> but currently I run it from the command prompt to make the situation as
>> simple as possible.
>>     
>
> So this does fail in command mode?  Wow.
>
> That's impressive :)
>
> Just so you know, some video drivers install apache httpd, and if they are
> responsible they use an alternate path and service name.  But perhaps this
> one corrupted your environment, and httpd tends to look into that regkey
> value for Apache2 to snag defaults, which is why I suggested you delete it.
>   


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message