httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abel Braaksma <abel.onl...@xs4all.nl>
Subject [users@httpd] After restart Vista, working Apache 2.2.11 stopped working, reinstall, google, etc to no avail
Date Fri, 15 May 2009 18:04:38 GMT
Hi all,

system: Windows Vista Business, latest SP's, Apache HTTPd 2.2.11, MSI 
installation.

I've had a long-running well-working Apache, no problems, changed some 
configs today and restarted Apache and all was fine and dandy. Then I 
installed a new video driver today and after restart, Apache didn't 
start at all anymore with the following message in error.log:

[notice] Apache/2.2.11 (Win32) configured -- resuming normal operations
[notice] Server built: Dec 10 2008 00:10:06
[crit] (22)Invalid argument: Parent: Failed to create the child process.
[crit] (OS 6)The handle is invalid.  : master_main: create child process 
failed. Exiting.
[notice] Parent: Forcing termination of child process 36

I tried the following things already and spent the better part of today 
trying to resolve this, to no avail:

 - restarted, re-installed and minimized the configuration to the bare 
essentials (no php, perl etc)
 - rollback to last restore point, so driver issues should be gone
 - disabled (exited!) any firewall, virus scanner, windows protection
 - tried several ways of reinstallation, each time completely removing 
old installation. Previously, a basic install worked on my system
 - google didn't give me new ideas
 - cleared arp, flushed dns, tried other ports then port 80
 - checked configuration with httpd -t .
 - ran httpd with -e debug (output from error.log below).
 - used SysInternals tools to check for any access denies or other weird 
things, but nothing of a sort

I'm running out of ideas. I don't know what "Invalid argument" means 
here. Though I am a programmer, I have not yet tried to install the 
source or tried to debug, it seemed to daunting.

Any help, hints, pointers would be greatly appreciated!

Thanks,

-- Abel --

PS: this question was also asked at experts-exchange, but got little 
response:

The full log from httpd -k start -l debug:

Starting the Apache2.2 service
The Apache2.2 service is running.
 mod_so.c(246): loaded module actions_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module alias_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module asis_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
auth_basic_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
authn_default_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
authn_file_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
authz_default_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
authz_groupfile_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
authz_host_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
authz_user_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
autoindex_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module cgi_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module dir_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module env_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
include_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module isapi_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
log_config_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module mime_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
negotiation_module
[Fri May 15 19:56:42 2009] [debug] mod_so.c(246): loaded module 
setenvif_module
[Fri May 15 19:56:43 2009] [notice] Apache/2.2.11 (Win32) configured -- 
resuming normal operations
[Fri May 15 19:56:43 2009] [notice] Server built: Dec 10 2008 00:10:06
[Fri May 15 19:56:43 2009] [crit] (22)Invalid argument: Parent: Failed 
to create the child process.
[Fri May 15 19:56:43 2009] [crit] (OS 6)The handle is invalid.  : 
master_main: create child process failed. Exiting.
[Fri May 15 19:56:43 2009] [notice] Parent: Forcing termination of child 
process 36




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message