httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: [users@httpd] Apache/2.0.47 - AIX - DEFLATE enabled - Content-Encoding for a page - shows blank - although it's gzip encoded
Date Tue, 05 May 2009 15:59:55 GMT
Arabinda Sahoo wrote:
> Hi Andre,
> 
> Can you send me the real good nuanced answer?
> 
:-)

Well, it might take a lot of time to get this right.
mod_headers is the general solution for setting headers.

But a first issue if that not all HTTP response headers can be set this 
way.  I know that for example the Content-Type is a different animal, 
because no matter what you do, Apache will reset it anyway.  the same 
may be true with Content-encoding, I just don't know.

Then the second aspect is that by setting this header with mod_headers, 
you probably would set it "too much", indiscriminately, for all pages in 
the same location, and not all your content necessarily matches that.
So you'll need to play with SetEnvIf and only do it in some cases, probably.

In a similar case before, I had to resort to a mod_perl output filter, 
to do this right.  This was with the Content-type header though, so I'm 
not really sure it is necessary in this case.

Is this nuanced enough ?



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message