httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Galić <i.ga...@brainsware.org>
Subject Re: [users@httpd] Apache not accepting php
Date Mon, 04 May 2009 08:49:19 GMT

Hi Jeff,

> I am trying to install and configure Apache, mySQL, and PHP on a
> Windows
> Vista PC.  I have installed all of the programs, but when I test a
> simple
> php test, I am only seeing the html.  I have modified httpd.conf in
> the
> /conf folder to include: 
>   #
>     AddType application/x-compress .Z
>     AddType application/x-gzip .gz .tgz
>     AddType application/x-httpd-php .php
> #BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
> PHPIniDir "C:/PHP/"
> LoadModule php5_module "C:/PHP/php5apache2_2.dll"
> #
> #END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL

AddType is a very old and grotty hack kind of way of deploying PHP on apache.
Please read http://www.devside.net/articles/php which explains this, and how
to get it right.

Also make sure that your PHP files start with <?php --
Or that 
http://at2.php.net/manual/en/ini.core.php#ini.short-open-tag
is set to 1.
 
> Any suggestions would be apprecitated.
> 
> - Jeff

Bye,
Igor

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message