httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marius Hanganu <mhang...@tremend.ro>
Subject [users@httpd] HTTP Headers appear in HTML page
Date Wed, 08 Apr 2009 04:36:27 GMT
Hello,

I'm facing this weird issue on a gentoo machine with apache 2.2 +
mod_proxy + tomcat.

Some .htm pages (not all) contain - right on top of the page - a dump
of the HTTP headers. Something like:

HTTP/1.1 0 Server: Apache-Coyote/1.1 Set-Cookie: JSESSIONID=....

This is not because of Tomcat, since pages requested directly by
Tomcat (on port 8080) don't have this problem so it must have
something to do with apache.

Furthermore, I get the string "2000" every 8360 characters (less or
more). The string "2000" appears in what it seems to be random places
(the difference between positions is about 8360 - although not
constant) and it breaks all kind of HTML elements and looks like "<sty
2000 le=" or "<br 2000 />", etc.

It looks like it has something to do with the header HTTP/1.1 200 -
which loses the "20" and all I receive is "HTTP/1.1 0" ...

I have no clue how to get a handle on this problem. Nothing on the
web. Has anyone come across this problem?

Thanks!
Marius

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message