httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Mearns <mearn...@gmail.com>
Subject Re: [users@httpd] HTML source rather than rendered page with mod_proxy_ajp
Date Tue, 28 Apr 2009 13:27:17 GMT
On Tue, Apr 28, 2009 at 8:43 AM, mr_b <rainer.simon@gmx.at> wrote:
> Hi! I run use mod_proxy_ajp to run several JBosses behind an Apache HTTP
> server (OS is Centos5). My problem: "occasionally" the browser displays the
> HTML source code of the page rather than the rendered page itself. (Sorry
> for not being more specific - I really couldn't find any reproducible cause
> or pattern yet. Happens with small pages as well as large ones). I
> configured virtual hosts in my http.conf like that: ServerName
> myserver01.mydomain DocumentRoot /var/www/html ProxyPass / ajp:// Any idea
> about what's causing this appreciated! Thanks!
> ________________________________
> View this message in context: HTML source rather than rendered page with
> mod_proxy_ajp
> Sent from the Apache HTTP Server - Users mailing list archive at Nabble.com.
>

This probably isn't much help (sorry, don't know much about proxying,
or anything about JBosses), but the problem (assuming it's not a
bizarre browser bug) is almost definitely caused by sending the
incorrect content-type header to the client. It should be text/html,
not text/plain. Why the wrong type is getting sent, I have no idea.

-Brian

-- 
Feel free to contact me using PGP Encryption:
Key Id: 0x3AA70848
Available from: http://keys.gnupg.net

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message