httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Mearns <mearn...@gmail.com>
Subject Re: [users@httpd] Problem with Mod_Rewrite
Date Tue, 14 Apr 2009 17:58:04 GMT
On Tue, Apr 14, 2009 at 1:43 PM, ricardo13 <ricardoogrande@gmail.com> wrote:
>
> Hi all,
>
> This line "RewriteRule ^/index.html$ new.html" shows error.
> But "RewriteRule /index.html$ new.html" sucess !!!
>
> And if I put the follow:
>  RewriteRule ^/test.html$ index.html
>
> But I haven't test.html !!! What's happen ???
>
> Ricardo
>

You don't need to have test.html, that's the point of a rewrite rule
is that it takes one address (which may or may not be valid on it's
own) and treats it like a different address (index.html, in this
case).

Turn on your rewrite log as previously directed, and check there to
start debugging your problem. If you need more help, be explicit about
what behavior you see with each thing you try. Simply saying "it
works" or "it errors" is not helpful for figuring out the problem, you
need to specify how you know it doesn't work, what you're seeing in
your browser, what you're seeing in the logs, etc.

-Brian



-- 
Feel free to contact me using PGP Encryption:
Key Id: 0x3AA70848
Available from: http://keys.gnupg.net

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message