httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steffen Tronstad" <s...@nextgentel.com>
Subject RE: [users@httpd] Help configuring Apache2 + SSL + namebased vhosts
Date Wed, 04 Mar 2009 13:37:23 GMT
I've created the certificate and all this.

I do not get any output from apache, other than failed!.

/etc/init.d/apache2 start
Starting web server (apache2)... failed!


My error.log doesnt get updated with any errors.



apache2ctl -S
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:443                  is a NameVirtualHost
         default server mydomain.no (/etc/apache2/sites-enabled/mydomain.no:18)
         port 443 namevhost mydomain.no (/etc/apache2/sites-enabled/mydomain.no:18)
*:80                   is a NameVirtualHost
         default server mysql.mydomain.no (/etc/apache2/sites-enabled/000-default:4)
         port 80 namevhost mysql.mydomain.no (/etc/apache2/sites-enabled/000-default:4)
         port 80 namevhost mydomain.com (/etc/apache2/sites-enabled/mydomain.com:1)
         port 80 namevhost mydomain.no (/etc/apache2/sites-enabled/mydomain.no:1)
         port 80 namevhost mydomain.ny (/etc/apache2/sites-enabled/mydomain.ny:1)
         port 80 namevhost www.mydomain.ny (/etc/apache2/sites-enabled/mydomain.ny:17)
         port 80 namevhost ingame.mydomain.no (/etc/apache2/sites-enabled/ingame.mydomain.no:1)
         port 80 namevhost noje.mydomain.no (/etc/apache2/sites-enabled/noje.mydomain.no:1)
Syntax OK




-----Opprinnelig melding-----
Fra: Brian Mearns [mailto:mearns.b@gmail.com] 
Sendt: 4. mars 2009 14:32
Til: users@httpd.apache.org
Emne: Re: [users@httpd] Help configuring Apache2 + SSL + namebased vhosts

On Wed, Mar 4, 2009 at 8:18 AM, Eric Covener <covener@gmail.com> wrote:
> On Wed, Mar 4, 2009 at 8:13 AM, Steffen Tronstad <sttr@nextgentel.com> wrote:
>> Now  I have to add SSL support for one of my domains, so I add Listen 443 to
>> my ports.conf, changes all <VirtualHost *> to <VirtualHost *:80> and
create
>> a new <VirtualHost *:443> for my SSL site. I also change/add NameVirtualHost
>> *:80 and *:443 in my 'default' file.
>>
>> This doesnt work at all. What am I doing wrong?
>>
>
> That looks exactly right.
>
> Can you elaborate on "doesn't work" and include the output of
> apachectl/apache2ctl/httpd -S and maybe your SSL config?
>
> --
> Eric Covener
> covener@gmail.com
>

Just listening on 443 won't cut it, it does actually take a little
work to get SSL set up. Specifically, you need to create some
certificates and configure apache to use them, not to mention turning
on SSL. If you already did this, then like Eric said, you'll need to
be more specific about the behavior you're seeing.

-Brian

-- 
Feel free to contact me using PGP Encryption:
Key Id: 0x3AA70848
Available from: http://pgp.mit.edu/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message