httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Mearns <mearn...@gmail.com>
Subject Re: [users@httpd] Help configuring Apache2 + SSL + namebased vhosts
Date Wed, 04 Mar 2009 13:32:23 GMT
On Wed, Mar 4, 2009 at 8:18 AM, Eric Covener <covener@gmail.com> wrote:
> On Wed, Mar 4, 2009 at 8:13 AM, Steffen Tronstad <sttr@nextgentel.com> wrote:
>> Now  I have to add SSL support for one of my domains, so I add Listen 443 to
>> my ports.conf, changes all <VirtualHost *> to <VirtualHost *:80> and
create
>> a new <VirtualHost *:443> for my SSL site. I also change/add NameVirtualHost
>> *:80 and *:443 in my ’default’ file.
>>
>> This doesnt work at all. What am I doing wrong?
>>
>
> That looks exactly right.
>
> Can you elaborate on "doesn't work" and include the output of
> apachectl/apache2ctl/httpd -S and maybe your SSL config?
>
> --
> Eric Covener
> covener@gmail.com
>

Just listening on 443 won't cut it, it does actually take a little
work to get SSL set up. Specifically, you need to create some
certificates and configure apache to use them, not to mention turning
on SSL. If you already did this, then like Eric said, you'll need to
be more specific about the behavior you're seeing.

-Brian

-- 
Feel free to contact me using PGP Encryption:
Key Id: 0x3AA70848
Available from: http://pgp.mit.edu/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message