httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From paredes <pare...@aecom.yu.edu>
Subject Re: [users@httpd] DBDDriver-mysql conflicts with php-mysql module
Date Wed, 11 Mar 2009 22:49:34 GMT
Investigating further, I found a similar complain at 
http://bugs.php.net/bug.php?id=45995  In that case the issue was 
"solved" by using apr / apr-util < 1.3  So I rebuilt Apache using apr & 
apr-util version 1.2.11 and now mod_authn_dbd and php built with mysql 
support work as documented.

Any ideas if this is a MySQL or php or Apache bug?

Regards,
-bill

paredes wrote:
> Greetings!
>
> OSX 10.5.6; Apache 2.2.11 [using built in apr & apr-util]; Mysql 
> 5.0.77; Php 5.2.9 [all 64 bit builds]
>
> I've been able to get Apache authentication / authorization to work as 
> documented both with LDAP, MySQL & LDAP failing to MySQL.
> However, when I build mysql support into php, apache is no longer able 
> to authenticate against mysql even though it is able to execute 
> php/mysql  scripts.
>
> Digging further I see apachelogs returning these error entries 
> whenever I start apache with mysql support for php enabled:
> [error] (20014)Internal error: DBD: Can't connect to mysql
> [error] (20014)Internal error: DBD: Can't connect to mysql
> [error] (20014)Internal error: DBD: failed to initialise
> [error] (20014)Internal error: DBD: failed to initialise
> [error] (20014)Internal error: DBD: Can't connect to mysql
> [error] (20014)Internal error: DBD: failed to initialise
> [error] (20014)Internal error: DBD: Can't connect to mysql
> [error] (20014)Internal error: DBD: failed to initialise
> [error] (20014)Internal error: DBD: Can't connect to mysql
> [error] (20014)Internal error: DBD: failed to initialise
>
> To isolate this I then reconfigured php disabling all modules except 
> for apxs ~ then apache - mysql authentication worked fine.
> Reconfiguring the remaining modules into php except for mysql support 
> ~ apache - mysql authentication still works.
> But when I include --with mysql to php's configure I get the errors 
> listed above and I'm no longer able to authenticate via mysql.
>
> Authentication via LDAP is not affected.
>
> It appears that php-mysql is clobbering apache/apr-util's mysql driver.
>
> Regards,
> -bill
>
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server 
> Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message