httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anthony J. Biacco" <>
Subject RE: [users@httpd] Build issue
Date Fri, 13 Mar 2009 16:24:13 GMT
Try putting the openssl bin directory in your PATH and the openssl lib
directory in your LD_LIBRARY_PATH




Manager, IT Operations

Format Dynamics, Inc.

303-573-1800x27 <> <> 


From: Rex Binns [] 
Sent: Friday, March 13, 2009 8:51 AM
To: users
Subject: [users@httpd] Build issue


Hello all.

I'm trying to compile Apache 2.2.11 on a Solaris 10 box and have run
into some issues.

When I run my configure with the  --with-ssl option set to the installed
location of my openSSL 0.9.8j binaries, I get a failure during configure
saying that the SSLeay libraries are not found.

checking for OpenSSL version... checking openssl/opensslv.h usability...
checking openssl/opensslv.h presence... yes
checking for openssl/opensslv.h... yes
checking openssl/ssl.h usability... yes
checking openssl/ssl.h presence... yes
checking for openssl/ssl.h... yes
  forcing SSL_LIBS to "-lssl -lcrypto -lsocket -lnsl -ldl  "
  adding "-lssl" to LIBS
  adding "-lcrypto" to LIBS
  adding "-lsocket" to LIBS
  adding "-lnsl" to LIBS
  adding "-ldl" to LIBS
checking openssl/engine.h usability... yes
checking openssl/engine.h presence... yes
checking for openssl/engine.h... yes
checking for SSLeay_version... no
checking for SSL_CTX_new... no
checking for ENGINE_init... no
checking for ENGINE_load_builtin_engines... no
checking for SSL_set_cert_store... no
configure: error: ... Error, SSL/TLS libraries were missing or unusable

My build line for this configuration is: ./configure
--enable-layout=Sprint --enable-mods-shared=all --enable-ssl=shared
--enable-ssl --with-ssl=/tools/apache/openssl --enable-so
--with-mpm=prefork --enable-v4-mapped --enable-logio --enable-info
--enable-proxy --enable-cgi --enable-cgid

If I run configure with the --with-ssl option set to the location of the
openSSL 0.9.8j source tree, configure works fine, but make fails when
building ab with undefined symbols (BIO_set_callback,
BIO_set_callback_arg and SSL_CTX_set_info_callback)

/tools/apache/build/httpd-2.2.11/srclib/apr/libtool --silent --mode=link
gcc -g -O2     -L/usr/local/lib -R/usr/local/lib
-R/tools/apache/build/openssl-0.9.8j/lib -L/usr/sfw/lib   -o ab  ab.lo
-lm /tools/apache/build/httpd-2.2.11/srclib/pcre/
/tools/apache/build/httpd-2.2.11/srclib/apr-util/ -lexpat
-liconv /tools/apache/build/httpd-2.2.11/srclib/apr/ -luuid
-lsendfile -lrt -lsocket -lnsl -lpthread -lssl -lcrypto -lsocket -lnsl
Undefined                       first referenced
 symbol                             in file
BIO_set_callback                    .libs/ab.o
BIO_set_callback_arg                .libs/ab.o
BIO_get_callback_arg                .libs/ab.o
SSL_CTX_set_info_callback           .libs/ab.o
ld: fatal: Symbol referencing errors. No output written to .libs/ab
collect2: ld returned 1 exit status

My build line for this configuration is: ./configure
--enable-layout=Sprint --enable-mods-shared=all --enable-ssl=shared
--enable-ssl --with-ssl=/tools/apache/build/openssl-0.9.8j
--with-mpm=prefork --enable-v4-mapped --enable-logio --enable-info
--enable-proxy --enable-cgi --enable-cgid --enable-so

openSSL was built using this line:   ./Configure solaris64-sparcv9-gcc
no-shared --prefix=/tools/apache/openssl

PATH and MANPATH are the same for both openSSL and Apache..

Any help with what I'm doing wrong here would be greatly appreciated.

View raw message